Data Domain: Cloud tier unit showed as "Delete-Pending" after removing
Summary: This article describes an issue with Cloud tier unit removal unsuccessful. The Cloud Tier unit is not removed, and it is shown by the system as Delete-Pending.
Symptoms
DD Cloud Tier is a native feature of DD OS 6.0 (or higher) for moving data from the active tier to low-cost, high-capacity object storage in the public, private, or hybrid cloud for long-term retention. The issue below may appear when a Cloud tier is deleted.
Sometimes, if the system cannot access the unit cloud, the removed cloud tier is shown as "Delete-pending" when the command "#cloud unit list" is issued as showed below:
sysadmin@datadomainKB# cloud unit list Name Profile Status ------------- --------------------- -------------- RemovedUnitCl RemovedUnitCl_profile Delete-Pending NewUnitCl NewUnitClprofile Active ------------- --------------------- --------------
This issue may be accompanied by the following alert, which is soon cleared:
EVT-CLOUD-00001 Unable to access provider for cloud unit <Cloud_unit_name>.
Cause
The above scenario may arise if a customer trying delete to un-used cloud unit in one of the following conditions.
- Cloud Service provider is no longer available.
- Customer has deleted S3 bucket/Blob Container used by Data domain Cloud unit directly from storage provider or third party utilities
- Object storage used at the backend has been decommissioned.
Resolution
There is no impact on the Data Domain. A downtime is required to fix this issue as the File System must be restarted to remove the Cloud Unit tier.
Contact DELL Support by creating a new Support Request or chat request for assistance.
- Customer's cloud storage admin's take responsibility to delete data from respective Object Storage.
- Failure to remove data from Object Storage may result in on-going billing from the cloud storage provider