NetWorker: Backup or Restore fails with the error "Resource does not exist"

Summary: "Resource Does not Exist" - Pop ups on NMC UI. Backup and restore fails with the specific open for the Workflow.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

"Resource Does not Exist" - Pop ups on NMC under Groups, Clients, Workflow, Policy, and Actions. 

 Resource does not exist pop-up error appears  

This issue also causes Backup Failure at times and also the restore of the Client.

Cause

When the Client is deleted from the NMC without clearing that Client in Group Properties, the Group Database is sometimes not updated. This can result in an error stating “Resource Does not Exist." It can also cause backup or restore failures for workflows associated with that Group. These issues occur when the Group and Database are not properly synchronized.

Resolution

The resolution for this display message can be fixed from the NMC by following the below steps:

  1. Go to "Protection" Tab.
  2. Select "Group."
  3. Go to "Group Properties" of the current group.
  4. Check whether any client has been selected on Group Properties, but which reflects as 0 clients available on NMC.
  5. At this point, check any Client under Group Properties and Click "Ok."
  6. Again open group properties and uncheck the Client checked in order to update the Database of that group with Clients.
  7. This updates the Database of the Group.
  8. Now switch any other group and when clicking this group, no pop-ups occur.

Additional Information

If there is an issue even after following the above steps, then follow up the KB: 'Resource Does Not Exist' open after client belonging to a group has been removed

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000031101
Article Type: Solution
Last Modified: 06 أبريل 2026
Version:  4
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