ECS: Dial Home - EKMServerConnectionStatus - Código do sintoma: 1369 e 1370
Summary: Este é um dial home foi introduzido para detectar o alerta EKMServerConnectionStatus.
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Symptoms
O ECS discou para home com o seguinte alerta:
| SymptomCode | Gravidade |
| 1369 | AVISO |
| 1370 | ERROR |
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<TransType>10</TransType>
<TransTypeDesc>EventXML</TransTypeDesc>
<TransID>0</TransID>
<Node Status="Unknown" State="Unknown" ID="ECSQE00079">
<Identifier>
<DeviceState>1</DeviceState>
<DeviceStatus>1</DeviceStatus>
<ClarifyID>ECSQE00079</ClarifyID>
<SiteName>UNKNOWN</SiteName>
<Vendor>EMC</Vendor>
<DeviceType>ElasticCloudStorageApp</DeviceType>
<Model>ElasticCloudStorage</Model>
<SerialNumber>ECSQE00079</SerialNumber>
<WWN>ECSQE00079</WWN>
<Platform>platform</Platform>
<OS>SLES</OS>
<OS_VER>12.3</OS_VER>
<UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
<EmbedLevel>2</EmbedLevel>
<InternalMaxSize>512800</InternalMaxSize>
<Comment>Object Alert</Comment>
</Identifier>
<Connection>
<ConnectType>ESRS</ConnectType>
<IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
<ConnectNum>xx.xxx.xxx.xx</ConnectNum>
<Port>22</Port>
</Connection>
<HeartBeat>
<HBStatus></HBStatus>
<HBState></HBState>
</HeartBeat>
<InternalData>
<FileList/>
<EventList>
<Event>
<SymptomCode>1370</SymptomCode>
<Category>Configuration</Category>
<Severity>Error</Severity>
<Status>Unknown</Status>
<Component>Object</Component>
<ComponentID></ComponentID>
<SubComponent>EKM Server Connection Status</SubComponent>
<SubComponentID></SubComponentID>
<CallHome>true</CallHome>
<FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
<LastTime>2022-01-29T07:32:09.718Z</LastTime>
<Count>0</Count>
<EventData><![CDATA[]]></EventData>
<Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
</Event>
</EventList>
</InternalData>
<ExternalFiles/>
</Node>
</ConnectHome>
Cause
O servidor de gerenciamento de chaves extensível (EKM) não está respondendo. Verifique se o servidor está conectado.
Resolution
Verificar status
Comando:
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatusExemplo:
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
<SensorId>KMServerConnectionStatus</SensorId>
<ListSensorStatus>
<SensorStatusRestRep>
<ContextId>EKMServerConnectionStatus</ContextId>
<CurrentState>OK</CurrentState>
<NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
<PreviousState>OK</PreviousState>
<Time>1551118064264</Time>
</SensorStatusRestRep>
</ListSensorStatus> Procure CurrentState como mencionado acima. Se definido como OK, o erro poderá ser ignorado. Se não estiver OK (aviso ou erro), prossiga com as etapas de solução de problemas abaixo.
Solução de problemas
Localize o servidor indicado na mensagem de alerta recebida e tente fazer ping nele:Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>Verifique resourcesvc.log mensagens sobre o problema EKM server:
Command:
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
Exemplo:
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
Os erros indicam um possível problema de rede no ambiente. A comunicação entre o ECS e o servidor EKM pode estar bloqueada ou o próprio servidor EKM pode estar indisponível. Verifique se o ECS pode fazer ping no servidor EKM e aconselha o usuário a verificar se o servidor EKM está funcionando.
Se não for possível resolver o problema, abra um chamado com o suporte do ECS para ajudar com as informações coletadas acima.
Se não for possível resolver o problema, abra um chamado com o suporte do ECS para ajudar com as informações coletadas acima.
Affected Products
ECS, ECS Appliance, ECS Software, Elastic Cloud StorageArticle Properties
Article Number: 000038620
Article Type: Solution
Last Modified: 17 ديسمبر 2025
Version: 7
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