ECS: Dial Home - Ref_ID: BtreeDiskLevelGC: código del síntoma: 1325

Summary: Este es un Call Home introducido en ECS 3.3 para detectar Alerta.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Un sistema ECS se comunicó con la siguiente alerta. 

<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="psnt1">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>psnt1</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>psnt1</SerialNumber>
            <WWN>ECSQE00077</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4352.834410f</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>sandy-maize.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.197.2</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1325</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Warning</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>BTREE Disk GC</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T20:05:09.755Z</FirstTime>
                    <LastTime>2019-01-29T20:05:09.755Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[Capacity free-up throughput is too slow to catch up with system metadata garbage collection. Please involve ECS engineering.  [Ref_ID : BtreeDiskLevelGC]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

 

Cause

Btree GC funciona lento en la etapa libre de capacidad del disco. Esta alerta se genera cuando hay más de 1 TB de elementos no utilizados pendientes de eliminación y la diferencia entre el porcentaje de recuperación de fragmentos de elementos no utilizados y el porcentaje de recuperación de capacidad de elementos no utilizados es superior a 100 GB. La alerta se envía cuando el sistema ha estado en este estado durante 7 días.

Resolution

  1. Conéctese a uno de los nodos del clúster a través de una sesión de PuTTY.
  2. Verifique el estado actual del sensor.
Comando:
svc_rest_cmd /vdc/sensor/status/BtreeDiskLevelGC
# svc_rest_cmd /vdc/sensor/status/BtreeDiskLevelGC
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>BtreeDiskLevelGCC</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>BtreeDiskLevelGC</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>47b32995-35fc-4593-8f3c-39c878fb10ad</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551104230509</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
  1. <Busque CurrentState>. Si está configurado en OK, el error no está activo y es probable que se trate de una falsa alerta. Ignore la alerta, pero si se activa nuevamente dentro de la próxima semana, abra una solicitud de servicio con el soporte técnico

Affected Products

ConnectEMC, ECS Appliance
Article Properties
Article Number: 000038657
Article Type: Solution
Last Modified: 17 ديسمبر 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.