ECS: Ring hem – Ref_ID: BtreeDiskLevelGC – Symptomkod: 1325

Summary: Det här är en uppringning som introducerades i ECS 3.3 för att identifiera Alert.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ett ECS-system har ringt hem med följande varning. 

<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="psnt1">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>psnt1</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>psnt1</SerialNumber>
            <WWN>ECSQE00077</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4352.834410f</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>sandy-maize.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.197.2</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1325</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Warning</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>BTREE Disk GC</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T20:05:09.755Z</FirstTime>
                    <LastTime>2019-01-29T20:05:09.755Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[Capacity free-up throughput is too slow to catch up with system metadata garbage collection. Please involve ECS engineering.  [Ref_ID : BtreeDiskLevelGC]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

 

Cause

Btree GC fungerar långsamt i det lediga stadiet för diskkapacitet. Den här aviseringen genereras när det finns mer än 1 TB skräp som väntar på borttagning och skillnaden mellan återvinningsfrekvensen för skräpsegment och återvinningsfrekvensen för skräpkapacitet är större än 100 GB. Varningen skickas när systemet har varit i det här tillståndet i 7 dagar.

Resolution

  1. Anslut till en av noderna i klustret via en putty-session.
  2. Kontrollera aktuell sensorstatus.
Kommando:
svc_rest_cmd /vdc/sensor/status/BtreeDiskLevelGC
# svc_rest_cmd /vdc/sensor/status/BtreeDiskLevelGC
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>BtreeDiskLevelGCC</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>BtreeDiskLevelGC</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>47b32995-35fc-4593-8f3c-39c878fb10ad</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551104230509</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
  1. Leta efter <CurrentState>, om den är inställd på OK är felet inte aktivt och detta är troligen en falsk varning. Ignorera varningen, men om den utlöses igen inom nästa vecka öppnar du en tjänstebegäran hos teknisk support

Affected Products

ConnectEMC, ECS Appliance
Article Properties
Article Number: 000038657
Article Type: Solution
Last Modified: 17 ديسمبر 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.