VPLEX: AMP(Array Management Provider) 연결 문제 해결

Summary: AMP 연결 상태가 "연결할 수 없음"을 보고하거나 AMP 등록이 'AMP를 ping하지 못했습니다.... 원인: 연결할 수 없음'이라는 메시지가 표시됩니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 고객 네트워크의 가능한 변화
  • 방화벽 구성 변경
  • AMP 호스트 변경사항
  • AMP 연결 상태가 "연결할 수 없음"을 보고합니다.
    /clusters/cluster-1/storage-elements/array-providers/AMP_NAME
    
    Attributes:
    Name Value
    ------------------- ------------
    array -
    connectivity-status unreachable
    ip-address X.X.X.X
    port 5989
    provider-type SMI-S
    use-ssl true
    username admin
  • AMP를 등록하려고 하면 다음 오류 메시지와 함께 실패합니다.
    amp register: Evaluation of <<amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c cluster-1>> failed.
    cause: Failed to register array management provider.
    cause: Failed to ping AMP 'AMP_NAME'. com.emc.vplex.via.orca.amp.AMPException: Failed to ping provider 'AMP_NAME'. Cause: Unable to connect

 

Cause

  • VPlex 관리 서버/MMCS와 AMP 호스트 간의 IP 연결 문제
  • 기존 방화벽 규칙 변경
  • SMI-S Provider의 자격 증명 변경

 

Resolution

  1. 관리 서버(VS2) 또는 MMCS(VS6)에서 AMP 호스트의 IP 주소를 Ping하여 ping이 가능한지 확인합니다. IP를 ping할 수 없는 경우 VPlex 관리 서버/MMCS 간의 연결 문제가 해결되었는지 확인합니다.

    service@ManagementServer:~> ping X.X.X.X
  2. 기존 AMP 컨피그레이션의 연결 상태가 "연결할 수 없음"을 보고하는 경우 VPlexcli에서 등록을 취소한 다음 다시 등록합니다.

    VPlexcli:/> amp unregister -n AMP_NAME -c cluster-1
    Unregistering an array-provider will permanently remove it. Do you wish to proceed? (Yes/No) Yes
    Successfully unregistered array provider 'AMP_NAME' on cluster 'cluster-1'.
  3. AMP를 등록하는 동안 URL은 프로토콜, 호스트 및 포트의 세 가지 값을 사용하여 생성됩니다. 관리 서버/MMCS가 등록 프로세스 중에 이 URL에 연결을 시도합니다. 이 URL에 액세스할 수 없는 경우 AMP 등록이 실패합니다. ECOM 서버에서 사용되는 프로토콜은 HTTP(5988) 또는 HTTPS(5989)입니다. 포트 443과 함께 두 포트 모두 방화벽 구성의 두 디렉터(인바운드 및 아웃바운드)에서 열려 있어야 합니다. 모든 방화벽 예외 목록은 이 문서 하단의 "EMC VIAS.pdf를 사용한 프로비저닝"이라는 PDF 첨부 파일을 참조하십시오.

    VIAS에 대한 SMI-S 방화벽 고려 사항 페이지 12
    TCP 방화벽 규칙 생성 페이지 13
    ECOM 보안(자격 증명) 설정 페이지 13
  4. 포트가 열려 있는지 확인하려면 관리 서버/MMCS에서 포트를 지정하여 AMP IP에 대한 텔넷을 수행합니다. 사용된 포트 중 하나라도 차단된 경우 위의 3단계를 참조하여 관련 포트가 방화벽에서 열려 있거나 허용되는지 확인합니다.

    포트 5988이 차단된 인스턴스:

    service@ManagementServer:~> telnet X.X.X.X 5988
    Trying X.X.X.X...
    telnet: connect to address X.X.X.X: Connection timed out

    포트 5989가 열려 있는 인스턴스:

    service@essvplex0415-mc:/var/log/VPlex/cli> telnet X.X.X.X 5989
    Trying X.X.X.X...
    Connected to X.X.X.X.
    Escape character is '^]'.
    Connection closed by foreign host.
  5. HTTPS(포트 5989)를 사용하여 AMP를 등록하려는 경우 --use-ssl 인수가 지정되었는지 확인합니다.

    VPlexcli:/> amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c CLUSTER_ID --use-ssl
  6. AMP 등록을 위한 기본 'admin' 자격 증명은 다음과 같습니다(VPlex 관리자 비밀번호가 아닙니다!).

    사용자: admin
    비밀번호: #1Password

  7. 위의 모든 단계를 수행해도 문제가 해결되지 않으면 AMP 호스트를 재부팅한 다음 AMP를 등록해 보십시오. 등록 프로세스가 계속 실패하면 Dell에 서비스 요청을 제출하십시오.

 

Affected Products

VPLEX GeoSynchrony

Products

VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000050148
Article Type: Solution
Last Modified: 29 يناير 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.