VPLEX: Усунення несправностей з підключенням провайдера управління масивами (AMP)
Summary: Кроки усунення несправностей, коли стан підключення AMP повідомляє про «недосяжний» і/або при зареєстрації AMP не працює з помилкою «Не вдалося пінгувати AMP.... Причина: Не можу підключитися». ...
Symptoms
- Можливі зміни в мережі клієнта
- Зміна конфігурації міжмережевого екрану
- Зміни на AMP-хості
- Звіти про стан підключення AMP «недосяжний»
/clusters/cluster-1/storage-elements/array-providers/AMP_NAME Attributes: Name Value ------------------- ------------ array - connectivity-status unreachable ip-address X.X.X.X port 5989 provider-type SMI-S use-ssl true username admin
- Спроба зареєструвати AMP не дає результату наступного повідомлення про помилку;
amp register: Evaluation of <<amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c cluster-1>> failed. cause: Failed to register array management provider. cause: Failed to ping AMP 'AMP_NAME'. com.emc.vplex.via.orca.amp.AMPException: Failed to ping provider 'AMP_NAME'. Cause: Unable to connect
Cause
- Проблеми з IP-з'єднанням між сервером управління VPlex/MMCS та хостом AMP.
- Зміни до чинних правил міжмережевого екрану
- Зміна облікових даних провайдера SMI-S
Resolution
-
Пінгуйте IP-адресу AMP-хоста з керуючого сервера (VS2) або MMCS (VS6), щоб переконатися, що він пінговується. Якщо IP-адреса не підлягає пінгу, переконайтеся, що будь-які проблеми зі з'єднанням між сервером управління VPlex/MMCS вирішені;
service@ManagementServer:~> ping X.X.X.X
-
Якщо статус зв'язку існуючої конфігурації AMP повідомляє про «недосяжний», зніміть її з VPlexcli і потім повторно зареєструйте;
VPlexcli:/> amp unregister -n AMP_NAME -c cluster-1 Unregistering an array-provider will permanently remove it. Do you wish to proceed? (Yes/No) Yes Successfully unregistered array provider 'AMP_NAME' on cluster 'cluster-1'.
-
Під час реєстрації AMP створюється URL за допомогою трьох значень: протокол, хост і порт. Сервер управління/MMCS намагається підключитися до цієї URL під час процесу реєстрації. Якщо ця URL недоступна, реєстрація AMP відбувається. Протокол, який використовує сервер ECOM, — це або HTTP (5988), або HTTPS (5989). Обидва порти разом із портом 443 мають бути відкриті в обох директорах (вхідний і вихідний) у конфігурації фаєрвола. Для переліку всіх винятків фаєрволу зверніться до PDF-вкладення внизу цієї статті під назвою «Provisioning with EMC VIAS.pdf»;
Міркування щодо міжмережевого екрану SMI-S для VIAS Сторінка 12 Створення правил міжмережевого екрану TCP Сторінка 13 Налаштування безпеки ECOM (облікові дані) Сторінка 13 -
Щоб перевірити, чи відкриті порти, зробіть telnet на IP-адресу AMP, вказавши порт/порти з керуючого сервера/MMCS. Якщо будь-який із використаних портів заблоковано, зверніться до кроку 3 вище, щоб переконатися, що відповідні порти відкриті або дозволені у міжмережевому екрані;
Випадок, коли порт 5988 заблоковано:
service@ManagementServer:~> telnet X.X.X.X 5988 Trying X.X.X.X... telnet: connect to address X.X.X.X: Connection timed out
Випадок, коли порт 5989 відкритий:
service@essvplex0415-mc:/var/log/VPlex/cli> telnet X.X.X.X 5989 Trying X.X.X.X... Connected to X.X.X.X. Escape character is '^]'. Connection closed by foreign host.
-
При спробі зареєструвати AMP за допомогою HTTPS (порт 5989) переконайтеся, що вказано аргумент --use-ssl;
VPlexcli:/> amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c CLUSTER_ID --use-ssl
-
Стандартні «адміністративні» облікові дані для реєстрації AMP такі (це не пароль адміністратора VPlex!)
Користувач:
admin
Пароль:#1Password -
Якщо всі вищезазначені кроки не допоможуть вирішити проблему, розгляньте можливість перезавантаження AMP-хоста, а потім спробуйте зареєструвати AMP. Якщо процес реєстрації все одно не вдасться, подайте запит на сервіс до Dell.