Backup del cluster Avamar SQL non riusciti con gap nel registro e file Sqlmeta.xml

Summary: Backup del cluster SQL Avamar non riusciti con gap di log e file sqlmeta.xml

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I backup incrementali SQL per un cluster SQL o SQL AG hanno esito negativo con i seguenti errori:

Line 542: 2019/12/05-16:49:56.85100 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 547: 2019-12-05 17:49:56 avsql Warning <7427>: Error loading SQL metadata
	Line 555: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 634: 2019-12-05 17:49:57 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewupdmgr' due to the following reason: A log gap was identified or a full backup was not found.
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 762: 2019-12-05 17:50:04 avsql Warning <7427>: Error loading SQL metadata
	Line 770: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 849: 2019-12-05 17:50:05 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewevent' due to the following reason: A log gap was identified or a full backup was not found.

 

Cause

Il problema del gap nel registro è causato dalla mancata lettura del file di sqlmeta.xml dai backup SQL precedenti e i backup hanno esito negativo con sqlmeta.xml non trovato.

 

Resolution

Controlla i passaggi seguenti:

  1. Creare "c:\temp" se non esiste, eseguire come admin mentre cd nella cartella BIN di Avamar sul nodo SQL primario:

    avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
    Nota: --labelnum="91631" è il numero dell'etichetta di backup.
  2. Verificare che il file sqlmeta.xml sia presente nell'output del comando precedente.

    Se il file è presente, provare a ripristinare ".system_info" dal backup utilizzando il comando seguente:

    avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
  3. Se il file sqlmeta.xml non esiste nell'etichetta di backup (sopra), prova questo:

    • Verificare se è presente un file sqlmeta.xml nella directory var del cluster/condivisa. Se il file esiste, eliminarlo o spostarlo in un'altra posizione.
    • Dopo aver eliminato/spostato il file, eseguire backup completi e quindi backup incrementali.
    • L'esecuzione di un backup completo seguito da un backup incrementale garantisce la creazione di un nuovo file di sqlmeta.xml.

 

Additional Information

Questo contenuto è tradotto in diverse lingue: 
https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf
https://downloads.dell.com/TranslatedPDF/DE_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf
https://downloads.dell.com/TranslatedPDF/FR_539981.pdf
https://downloads.dell.com/TranslatedPDF/IT_539981.pdf
https://downloads.dell.com/TranslatedPDF/JA_539981.pdf
https://downloads.dell.com/TranslatedPDF/KO_539981.pdf
https://downloads.dell.com/TranslatedPDF/NL_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf
https://downloads.dell.com/TranslatedPDF/RU_539981.pdf
https://downloads.dell.com/TranslatedPDF/SV_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000057398
Article Type: Solution
Last Modified: 22 مايو 2026
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.