Back-ups van Avamar SQL-cluster mislukt met logboekkloof en Sqlmeta.xml-bestand

Summary: Back-ups van Avamar SQL cluster zijn mislukt met logboekkloof en sqlmeta.xml-bestand

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Incrementele SQL-back-ups voor een SQL-cluster of SQL AG mislukken met de volgende fouten:

Line 542: 2019/12/05-16:49:56.85100 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 547: 2019-12-05 17:49:56 avsql Warning <7427>: Error loading SQL metadata
	Line 555: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 634: 2019-12-05 17:49:57 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewupdmgr' due to the following reason: A log gap was identified or a full backup was not found.
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 755: 2019/12/05-16:50:04.42799 [avsql_assist]  avspawn::run_and_wait back from wait error_num:536870919 wait_error:0
	Line 762: 2019-12-05 17:50:04 avsql Warning <7427>: Error loading SQL metadata
	Line 770: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found)
	Line 849: 2019-12-05 17:50:05 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewevent' due to the following reason: A log gap was identified or a full backup was not found.

 

Cause

Het probleem met de logboekonderbreking wordt veroorzaakt doordat het sqlmeta.xml-bestand van de vorige SQL-back-ups niet kan worden gelezen en de back-ups mislukken met sqlmeta.xml niet gevonden.

 

Resolution

Controleer de onderstaande stappen:

  1. Maak "c:\temp" als deze niet bestaat, voer dan uit als admin while cd in de Avamar BIN-map op het primaire SQL-knooppunt:

    avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
    Opmerking: --labelnum="91631" is het nummer van het back-uplabel.
  2. Controleer of het sqlmeta.xml bestand aanwezig is in de uitvoer van de bovenstaande opdracht.

    Als het bestand aanwezig is, probeer dan '.system_info' vanuit de back-up te herstellen met de onderstaande opdracht:

    avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
  3. Als het sqlmeta.xml bestand niet bestaat in het back-uplabel (hierboven), probeert u het volgende:

    • Controleer of er een sqlmeta.xml bestand in het cluster/de gedeelde var-directory staat. Als het bestand bestaat, verwijdert u het bestand of verplaatst u het naar een andere locatie.
    • Nadat u het bestand hebt verwijderd/verplaatst, voert u volledige back-ups en vervolgens incrementele back-ups uit.
    • Het uitvoeren van een volledige back-up gevolgd door een incrementele back-up zorgt ervoor dat een nieuw sqlmeta.xml bestand wordt gemaakt.

 

Additional Information

Deze inhoud is vertaald in verschillende talen: 
https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf
https://downloads.dell.com/TranslatedPDF/DE_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES_539981.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf
https://downloads.dell.com/TranslatedPDF/FR_539981.pdf
https://downloads.dell.com/TranslatedPDF/IT_539981.pdf
https://downloads.dell.com/TranslatedPDF/JA_539981.pdf
https://downloads.dell.com/TranslatedPDF/KO_539981.pdf
https://downloads.dell.com/TranslatedPDF/NL_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT_539981.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf
https://downloads.dell.com/TranslatedPDF/RU_539981.pdf
https://downloads.dell.com/TranslatedPDF/SV_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf
https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000057398
Article Type: Solution
Last Modified: 22 مايو 2026
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.