Falha nos backups de cluster SQL do Avamar com lacuna de log e arquivo Sqlmeta.xml
Summary: Falha nos backups do cluster SQL do Avamar com lacuna de log e arquivo sqlmeta.xml
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Os backups incrementais do SQL para um cluster SQL ou SQL AG apresentam falha com os seguintes erros:
Line 542: 2019/12/05-16:49:56.85100 [avsql_assist] avspawn::run_and_wait back from wait error_num:536870919 wait_error:0 Line 547: 2019-12-05 17:49:56 avsql Warning <7427>: Error loading SQL metadata Line 555: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found) Line 634: 2019-12-05 17:49:57 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewupdmgr' due to the following reason: A log gap was identified or a full backup was not found. Line 755: 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait back from wait error_num:536870919 wait_error:0 Line 755: 2019/12/05-16:50:04.42799 [avsql_assist] avspawn::run_and_wait back from wait error_num:536870919 wait_error:0 Line 762: 2019-12-05 17:50:04 avsql Warning <7427>: Error loading SQL metadata Line 770: avtar Error <5195>: Path ".system_info\sqlmeta" not found in backup. (Element 'sqlmeta' at position 1 in search path '.system_info\sqlmeta' not found) Line 849: 2019-12-05 17:50:05 avsql Error <40418>: Skipping database 'sql-listener\VIEWSQL/viewevent' due to the following reason: A log gap was identified or a full backup was not found.
Cause
O problema de lacuna de log é causado devido à falha na leitura do arquivo sqlmeta.xml dos backups SQL anteriores, e os backups falham com sqlmeta.xml não encontrados.
Resolution
Confira as etapas abaixo:
-
Crie "c:\temp", se ele não existir, execute como admin enquanto cd na pasta BIN do Avamar no nó SQL primário:
avtar --list --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig --logfile=c:\temp\backup_list.log
Nota: --labelnum="91631" é o número do rótulo de backup. -
Verifique se o arquivo sqlmeta.xml está presente na saída do comando acima.
Se o arquivo estiver presente, tente restaurar o .system_info do backup usando o comando abaixo:
avtar -x --debug --server=<Avamar_server> --id=MCUser --ap=MCUser_password --path=<path_to_client> --labelnum="91631" --noinfo --noconfig ".system_info" --target=c:\temp\ --logfile=c:\temp\system_info.log --internal
-
Se o arquivo sqlmeta.xml não existir no rótulo de backup (acima), tente o seguinte:
- Verifique se há algum arquivo sqlmeta.xml no diretório var compartilhado/cluster. Se o arquivo existir, exclua ou mova o arquivo para outro local.
- Depois de excluir/mover o arquivo, realize backups completos e, em seguida, backups incrementais.
- A execução do backup completo seguido pelo backup incremental garante a criação de um novo arquivo sqlmeta.xml.
Additional Information
Este conteúdo está traduzido diferentes idiomas:
| https://downloads.dell.com/TranslatedPDF/AR-SA_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_539981.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-TW_539981.pdf |
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000057398
Article Type: Solution
Last Modified: 22 مايو 2026
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.