Dell Unity: Es posible que no se pueda acceder a los recursos compartidos SMB o NFS debido a subprocesos bloqueados

Summary: Cómo manejar eventos de subprocesos bloqueados en un sistema Dell Unity. (Corregible por Dell)

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Symptoms

El propósito de este artículo es proporcionar orientación genérica sobre cómo manejar los eventos de subprocesos bloqueados, ya que el manejo adecuado es crucial para el análisis de causa raíz (RCA) y la corrección.

Hay otros artículos disponibles específicos para ciertas versiones de Unity OE, como el artículo 000002643: DTA 503606: Unity: Los arreglos que utilizan CIFS/SMB que ejecutan el entorno operativo (OE) 4.2.0.9392909 o 4.2.0.9433914 deben actualizarse al OE 4.2.0.9476662 (o posterior), el cual aborda un posible problema de falta de disponibilidad de datos. (Solo los usuarios registrados del soporte de Dell pueden acceder a este artículo).

Los servidores NAS, el sistema de archivos y los recursos compartidos se muestran en línea en el lado de Dell Unity, pero los subprocesos bloqueados hacen que los recursos compartidos SMB o NFS no estén disponibles para los clientes.

Posibles códigos de error:

13:102d0003
neo-13:102d0003
neo-13:102d0007

Cause

Los subprocesos son recursos que se utilizan para procesar solicitudes o acciones. Varios subsistemas tienen sus propios pools de subprocesos asignados.

Las causas de los subprocesos bloqueados son diferentes, y cada caso y sistema deben investigarse por separado.

Estas son algunas de las razones más comunes por las que pueden ocurrir: 
  • Interbloqueo en el que dos subprocesos están esperando el bloqueo de un recurso que pertenece al otro subproceso
  • Procesamiento extendido de operaciones (como autenticación retrasada, comprobación de virus, etc.)

Resolution

Para determinar si ha bloqueado subprocesos, busque los mensajes que se muestran en el siguiente ejemplo (sección Notas). Si se observan estos mensajes con registros de fecha y hora que coinciden con el problema, el SP en el cual se informan debe entrar en estado de alarma o reiniciarse para restaurar el acceso.

Solución inmediata (temporal):       
Un reinicio o un estado de alarma del SP que informa los mensajes de subprocesos bloqueados restaura el acceso inmediatamente. Un reinicio y un estado de alarma son esencialmente lo mismo; la única diferencia es que el estado de alarma proporciona un archivo de volcado de memoria para el análisis posterior.

Informativo:
  • Aunque un simple reinicio alivia temporalmente el problema, es probable que elimine la capacidad de RCA.
    • Solo un volcado de SP (alarma) recopilado mientras la condición está presente permite que el departamento de ingeniería de Dell investigue por completo y realice un RCA en la causa particular de los subprocesos bloqueados.
  • Solo Dell puede realizar una alarma de SP. Comuníquese con el soporte técnico de Dell o con su representante de servicio autorizado y mencione este ID de artículo de Dell.
  • Esta no es una corrección permanente y, si la causa subyacente de los subprocesos bloqueados no se resuelve, esto puede volver a ocurrir hasta que se implemente la corrección.
Corregir: 
Hay varias correcciones disponibles para resolver esta condición según la versión instalada del entorno operativo de Unity.

En los casos en que no existe una corrección, se requiere un estado de alarma de SP, ya que esto permite que Dell obtenga un archivo de volcado con la condición actual del arreglo para fines de revisión. Es posible que no sea posible realizar un RCA sin este archivo de volcado. Un estado de alarma de SP requiere acceso raíz.

Additional Information

Esto se ve en vivo en el sistema o en los registros.

/EMC/backend/log_shared solo está presente (montada) en el SP principal; debe estar en el SP principal (activo o en registros) para acceder a esta ubicación y a estos archivos.

En los mensajes de error, verá el SP afectado (el SP que se debe reiniciar):
service@spa~# zgrep -i blocked /EMC/backend/log_shared/EMCSystemLogFile*
EMCSystemLogFile.log:"2017-07-26T18:12:55.428Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 423 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
EMCSystemLogFile.log:"2017-07-26T18:27:55.474Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1323 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
EMCSystemLogFile.log:"2017-07-26T18:42:55.520Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 2222 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
 
Nota: Es posible que estos mensajes no siempre se encuentren en los registros anteriores, por lo que si no se encuentra nada en el EMCSystemLogFile registros, siempre verifique directamente en el ktraces sin duda.

La variable ktrace Los archivos se pueden ajustar rápidamente, por lo que es posible que estos mensajes no estén presentes en el archivo descomprimido más reciente. La recomendación sería comprobar todos los c4_safe_ktrace archivos (que se encuentran en /EMC/C4Core/log/).

En el SP afectado (el SP donde reside el servidor NAS afectado), vaya a /EMC/C4Core/log/ y ejecute el siguiente comando (asegúrese de que la palabra BLOQUEADO esté en mayúsculas). Si no está seguro de qué SP se ve afectado, ejecútelo en ambos y el SP afectado debe mostrar estos mensajes:
service@spa~# zgrep -h BLOCKED c4_safe_ktrace* | sort
...
2017/09/20-07:46:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 33730 seconds: Server operations may be impacted
2017/09/20-08:01:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 34630 seconds: Server operations may be impacted
2017/09/20-08:16:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 35530 seconds: Server operations may be impacted
2017/09/20-08:31:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 36430 seconds: Server operations may be impacted
2017/09/20-08:46:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 37330 seconds: Server operations may be impacted
2017/09/20-09:01:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 38230 seconds: Server operations may be impacted
2017/09/20-09:16:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 39130 seconds: Server operations may be impacted
2017/09/20-09:31:... sade:KERNEL: 3: 3:[core]  ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 40030 seconds: Server operations may be impacted

Affected Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family

Products

Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Hybrid
Article Properties
Article Number: 000058575
Article Type: Solution
Last Modified: 12 ديسمبر 2025
Version:  6
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