Dell Unity: SMB- eller NFS-resurser kan bli otillgängliga på grund av blockerade trådar
Summary: Hantera blockerade trådhändelser i ett Dell Unity-system. (Kan korrigeras av Dell)
Symptoms
Syftet med den här artikeln är att ge allmän vägledning om hur du hanterar blockerade trådhändelser, eftersom korrekt hantering är avgörande för rotorsaksanalys (RCA) och korrigering.
Det finns andra artiklar som är specifika för vissa Unity OE-versioner, till exempel artikel 000002643: DTA-503606: Unity: Disksystem som använder CIFS/SMB som kör Operating Environment (OE) 4.2.0.9392909 eller 4.2.0.9433914 bör uppgraderas till OE 4.2.0.9476662 (eller senare), vilket åtgärdar ett potentiellt problem med dataotillgänglighet. (Endast registrerade Dell-supportanvändare kan få åtkomst till den här artikeln.)
NAS-servrar, filsystem och resurser visas online på Dell Unity-sidan, men blockerade trådar gör att SMB- eller NFS-resurser inte är tillgängliga för klienter.
Möjliga felkoder:
13:102d0003 neo-13:102d0003 neo-13:102d0007
Cause
Det finns olika orsaker till blockerade trådar, och varje fall och system måste undersökas separat.
Här är några av de vanligaste orsakerna till att dessa kan uppstå:
- Dödläge där två trådar väntar på ett resurslås som ägs av den andra tråden
- Utökad åtgärdsbearbetning (t.ex. fördröjd autentisering, viruskontroll och så vidare)
Resolution
Omedelbar (tillfällig) lösning:
En omstart eller panik hos SP som rapporterar meddelanden om blockerade trådar återställer åtkomsten omedelbart. En omstart och en panik är i princip samma sak, den enda skillnaden är att paniken tillhandahåller en minnesdumpfil för efteranalys.
Informativt:
- Även om en enkel omstart tillfälligt lindrar problemet, tar det sannolikt bort möjligheten till RCA.
- Endast en SP-dump (panik) som samlas in medan tillståndet är närvarande gör att Dell Engineering kan fullständigt undersöka och RCA den specifika orsaken till blockerade trådar.
- Endast Dell kan utföra en SP-panik. Kontakta Dells tekniska support eller din auktoriserade servicerepresentant och uppge detta Dell-artikel-ID.
- Detta är inte en permanent lösning och om den underliggande orsaken till de blockerade trådarna inte är löst kan detta hända igen tills korrigeringen implementeras.
Det finns flera korrigeringar för att lösa det här problemet beroende på vilken Unity OE-version som är installerad.
Om det inte finns någon korrigering krävs en SP-panik eftersom det gör det möjligt för Dell att hämta en dumpfil med disksystemets aktuella tillstånd för granskning. RCA kanske inte är möjligt utan den här dumpfilen. En SP-panik kräver rotåtkomst.
Additional Information
/EMC/backend/log_shared finns (monterad) på den primära SP måste du vara på den primära SP (live eller loggar) för att få åtkomst till den här platsen och dessa filer.
I felmeddelandena visas den berörda SP (den SP som måste startas om):
service@spa~# zgrep -i blocked /EMC/backend/log_shared/EMCSystemLogFile* EMCSystemLogFile.log:"2017-07-26T18:12:55.428Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 423 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:27:55.474Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1323 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:42:55.520Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 2222 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
EMCSystemLogFile loggar, kontrollera alltid direkt i ktraces för att vara säker.
Informationen
ktrace Filer kan radbrytas snabbt, så dessa meddelanden kanske inte finns i den senaste okomprimerade filen. Rekommendationen är att kontrollera alla c4_safe_ktrace filer (finns i /EMC/C4Core/log/).
På berörd SP (den SP där den berörda NAS-servern finns) går du till
/EMC/C4Core/log/ och kör kommandot nedan (se till att ordet BLOCKED är i versaler). Om du är osäker på vilken SP som påverkas kör du detta på båda och den berörda SP bör visa följande meddelanden:
service@spa~# zgrep -h BLOCKED c4_safe_ktrace* | sort ... 2017/09/20-07:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 33730 seconds: Server operations may be impacted 2017/09/20-08:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 34630 seconds: Server operations may be impacted 2017/09/20-08:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 35530 seconds: Server operations may be impacted 2017/09/20-08:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 36430 seconds: Server operations may be impacted 2017/09/20-08:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 37330 seconds: Server operations may be impacted 2017/09/20-09:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 38230 seconds: Server operations may be impacted 2017/09/20-09:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 39130 seconds: Server operations may be impacted 2017/09/20-09:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 40030 seconds: Server operations may be impacted