Dell Unity: Акції SMB або NFS можуть стати недоступними через заблоковані потоки
Summary: Як обробляти заблоковані послідовні події в системі Dell Unity. (Dell Correctable)
Symptoms
Мета цієї статті — надати загальні рекомендації щодо обробки заблокованих подій, оскільки правильне оброблення є критично важливим для аналізу кореневих причин (RCA) та виправлення
.Існують й інші статті, специфічні для певних версій Unity OE, наприклад, статті 000002643: DTA 503606: Єдності: Масиви, що використовують CIFS/SMB, що працюють з операційним середовищем (OE) 4.2.0.9392909 або 4.2.0.9433914, повинні оновлюватися до OE 4.2.0.9476662 (або новішої версії), що вирішує потенційну проблему недоступності даних. (Доступ до цієї статті можуть доступні лише зареєстровані користувачі Dell Support.)
NAS-сервери, файлова система та спільні ресурси відображаються онлайн на стороні Dell Unity, але заблоковані потоки роблять SMB або NFS недоступними для клієнтів
.Можливі коди помилок:
13:102d0003 neo-13:102d0003 neo-13:102d0007
Cause
Існують різні причини блокування потоків, і кожен випадок та система мають розглядатися окремо.
Ось деякі з найпоширеніших причин, чому це може виникати:
- Глухий кут, коли два потоки чекають на блокування ресурсу, що належить іншому потоку
- Розширена обробка операцій (наприклад, відкладена автентифікація, перевірка на віруси тощо)
Resolution
Негайне (тимчасове) рішення:
Перезавантаження або паніка SP, який повідомляє про повідомлення про заблоковані потоки, одразу відновлює доступ. Перезавантаження і паніка — це по суті одне й те саме, єдина різниця в тому, що паніка надає файл дампу пам'яті для постаналізу.
Інформаційних:
- Хоча просте перезавантаження тимчасово вирішує проблему, ймовірно, це позбавляє можливості підключення до RCA.
- Лише SP-дамп (паніка), зібраний під час наявності стану, дозволяє інженерії Dell повністю розслідувати та перевірити RCA конкретну причину блокованих потоків.
- Лише Dell може виконати паніку SP. Зв'яжіться з технічною підтримкою Dell або вашим уповноваженим сервісним представником і процитуйте цей ID статті Dell.
- Це не є постійним виправленням, і якщо причина блокування потоків не буде вирішена, це може повторитися до реалізації виправлення.
Доступно кілька виправлень для вирішення цієї проблеми залежно від встановленої версії Unity OE.
У випадках, коли виправлення не існує, потрібна паніка SP , оскільки це дозволяє Dell отримати дамп-файл із поточним станом масиву для перегляду. RCA, можливо, неможливий без цього дамп-файлу. Паніка SP вимагає доступу до кореня.
Additional Information
/EMC/backend/log_shared присутній (монтований) лише на первинному SP, ви повинні бути на первинному SP (живому або журналі), щоб отримати доступ до цієї локації та цих файлів.
У повідомленнях про помилки ви бачите уражений SP (SP, який потрібно перезавантажити):
service@spa~# zgrep -i blocked /EMC/backend/log_shared/EMCSystemLogFile* EMCSystemLogFile.log:"2017-07-26T18:12:55.428Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 423 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:27:55.474Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1323 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL EMCSystemLogFile.log:"2017-07-26T18:42:55.520Z" "unitymgr01_spa" "Kittyhawk_safe" "12657" "unix/spa/root" "ERROR" "13:102d0003" :: "ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 2222 seconds: Server operations may be impacted ." :: Category=System Component=DART_KERNEL
EMCSystemLogFile Журнали, завжди перевіряйте безпосередньо у ktraces Звісно.
The
ktrace Файли можуть швидко обгортатися, тому ці повідомлення можуть не бути присутніми в останньому нестисненому файлі. Рекомендується перевірити всі c4_safe_ktrace Файли (знайдено у /EMC/C4Core/log/).
На ураженому SP (СП, де розташований уражений сервер NAS) перейдіть на
/EMC/C4Core/log/ і виконати команду нижче (переконайтеся, що слово BLOCKED написане великими літерами). Якщо не впевнені, який саме SP уражений, запустіть це на обох, і уражений SP має показувати такі повідомлення:
service@spa~# zgrep -h BLOCKED c4_safe_ktrace* | sort ... 2017/09/20-07:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 33730 seconds: Server operations may be impacted 2017/09/20-08:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 34630 seconds: Server operations may be impacted 2017/09/20-08:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 35530 seconds: Server operations may be impacted 2017/09/20-08:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 36430 seconds: Server operations may be impacted 2017/09/20-08:46:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 37330 seconds: Server operations may be impacted 2017/09/20-09:01:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 38230 seconds: Server operations may be impacted 2017/09/20-09:16:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 39130 seconds: Server operations may be impacted 2017/09/20-09:31:... sade:KERNEL: 3: 3:[core] ThreadsServicesSupervisor: Service:CIFS Pool:SMB2BLOCKED for 40030 seconds: Server operations may be impacted