Solutions Enabler: ECOM service fails often on SMI-S Provider A POST request for cimom is being rejected
Summary: ECOM service fails often on SMI-S Provider.
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This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ECOM service fails often on SMI-S Provider.
Several core files get generated during the crash.
Snippet from cimomlog:
Other logs does not provide any information as the timestamps are missing.
GDB on the core file gave the below information only.
Several core files get generated during the crash.
Snippet from cimomlog:
29-Jul-2019 17:33:34.767 -2304419584-E- NAVSSLSocket: NAVSSLSocket(): Ignoring exception thrown: shutdown : Transport endpoint is not connected 29-Jul-2019 17:38:47.650 -2304419584-E- NAVSSLSocket: NAVSSLSocket(): Ignoring exception thrown: shutdown : Transport endpoint is not connected 29-Jul-2019 17:39:34.746 -2063587072-E- NAVSSLSocket: NAVSSLSocket(): Ignoring exception thrown: shutdown : Transport endpoint is not connected 30-Jul-2019 10:33:37.699 -644822784-E- RequestHandler::process: A POST request for /cimom is being rejected, as the CIMOM is not yet started and the request is not over loopback. 30-Jul-2019 10:33:37.699 -644822784-E- RequestHandler::sendServiceUnavailable: Service unavailable: HTTP/1.1dev-smis-9/cimom 30-Jul-2019 10:33:40.818 -1588475712-W- OSLSProvider:symm: No assocations of type CIM_ReferencedProfile from instance root/emc:SE_RegisteredProfile%InstanceID=Array-+-1.2.0 30-Jul-2019 10:33:40.930 -1588475712-W- OSLSProvider:symm: No assocations of type CIM_ElementConformsToProfile from instance root/emc:SE_RegisteredProfile%InstanceID=Automated Storage Tiering-+-1.6.0
Other logs does not provide any information as the timestamps are missing.
GDB on the core file gave the below information only.
Core was generated by `ECOM -d -c /opt/emc/ECIM/ECOM/conf'. Program terminated with signal 11, Segmentation fault. #0 0x00007xxxxxxxxxx80 in ?? ()
Cause
The Operating System on the host in which Solutions Enabler is installed is incompatible.
Resolution
In this particular scenario we found that the OS is incompatible.
Solutions Enabler was installed on CentOS which is not supported as per eLabnavigator.
Installing Solutions Enabler on a compatible OS resolves the issue.
Solutions Enabler was installed on CentOS which is not supported as per eLabnavigator.
Installing Solutions Enabler on a compatible OS resolves the issue.
Affected Products
SMI-S Provider, Solutions EnablerProducts
SMI-S ProviderArticle Properties
Article Number: 000062115
Article Type: Solution
Last Modified: 11 نوفمبر 2025
Version: 4
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