L'agent DPA non si avvia

Summary: Questo articolo illustra un problema a causa del quale il servizio agent DPA non si avvia a causa di voci non valide o incomplete nel file di configurazione del dpaagent_config.xml.

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Symptoms

Quando si avvia il servizio agent DPA, non si avvia.

Se si inizia con i servizi di Windows, è possibile che venga visualizzata una finestra di errore come la seguente:
Errore del servizio EMC DPA Agent

 

Cause

La causa di questo problema non è nota in questo momento.

In un caso, è stato rilevato che il file dpagent_config.xml non era corretto e ciò ha causato il mancato avvio dell'agent.

 

Resolution

Per risolvere questo problema, è necessaria un'ulteriore procedura di risoluzione dei problemi.

Il file "dpaagent_config.xml" è accessibile all'avvio per configurare l'agent. Se i tag xml in questo file non sono completi, sono scritti in modo errato o mancanti, ciò può causare il mancato avvio dell'agent. In questo caso, l'agent non registra alcun errore.

Di seguito è riportato il contenuto del file "dpaagent_config.xml". Tutti questi tag dovrebbero essere presenti; potrebbero avere anche altri tag. Tutti questi elementi devono essere completi e scritti correttamente con dati validi:

<AGENTCONFIG>                                                                            Open tag.
    <VERSION>600</VERSION>                                                       Major Agent Version
    <AGENTVERSION>6.4.0.102611</AGENTVERSION>               Full Agent Version
    <SERVERNAME>127.0.0.1</SERVERNAME>                            IP or FQDN or DPA APP server this agent is assigned to.
    <SERVERPORT>9002</SERVERPORT>                                  Port on DPA APP server to connect to, this should always be 9002 unless APP server port was changed.
    <SERVERSSL>true</SERVERSSL>                                            Should always be set to true, to use SSL connection.
    <LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>   Path to the DPA agent log
    <LOGLEVEL>Info</LOGLEVEL>                                                  Current log level of the agent, not that the APP will override this setting, so change in the DPA GUI
    <LOGFILEMAXSIZE>99614720</LOGFILEMAXSIZE>                Max size of the dpa agent log file.
    <JREDIR>/opt/emc/dpa/services/_jre</JREDIR>                          Java directory.
</AGENTCONFIG>                                                                             Close tag, if there is anything after this tag the agent will not start.

Tutti i valori devono essere corretti in questo file, solo i valori servername e log level devono essere modificati. Se uno qualsiasi degli altri richiede modifiche, contattare il supporto Dell Technologies per assistenza.

Se uno dei tag è scritto in modo errato, o se manca una parte di essi, questo deve essere corretto. Ad esempio, in un caso il tag servername era mancante di una parte, come mostrato di seguito:

<SERVERNAME>127.0.0.1RVERNAME>

La parte mancante del tag "</SER" è stata aggiunta nuovamente e ciò ha risolto il problema consentendo l'avvio dell'agent.

Per ulteriori dettagli o informazioni, contattare il supporto tecnico Dell Technologies.

 

Article Properties
Article Number: 000167227
Article Type: Solution
Last Modified: 14 مايو 2026
Version:  5
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