PowerFlex: ESXi PNA deployments with OS10 switches may fail depending on the switch cabling

Summary: PowerFlex Manager installs operating systems during new service deployment or node expansion with Partial Network Automation using iDRAC virtual media. Sometimes when LACP networking is used with Dell OS 10 switches OS installation failures can be seen depending on the switch cabling used. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In /opt/Dell/ASM/deployments/<service_ID>/  log file, you may see something similar to this:

deploymentLog.png
 

Cause

For ESXi, LACP has to be configured after the node is added to vCenter. Prior to that the ESXi node will use only a single vmnic. This configuration is generally not compatible with LACP networking, but the "LACP fallback" option can be used to allow it to function. This feature allows the port channel to gracefully degrade to individual Ethernet ports when LACP traffic is not seen as is the case during PXE OS Installation. PowerFlex Manager uses the "LACP fallback" option to allow ESXi OS installation to proceed when LACP networking is requested.

However on Dell OS 10 switches, when "LACP fallback" is active only one of the two switch interfaces that are part of the LACP port channel is active. This can cause ESXi OS installation with PowerFlex Manager to fail if the first NIC port used for OS installation is not connected to the switch port that is active.

This document includes more details about which switch port will be elected as active: LACP fallback in VLT | Dell SmartFabric OS10 - Virtual Link Trunking - Reference Architecture Guide | Dell Technologies Info Hub 

 

Resolution

If Partial Network Automation OS installation fails with Dell OS 10 switches, find the switch interface connected to the first NIC port with the management network on it. Then log in to the switch, run "show port channel summary" and search for the port channel containing this switch interface. If it reports "D" for down then you may be affected by this issue. To confirm, find the switch interface connected to the second NIC port with the management network on it. Log in to the other switch and run "show port channel summary." If it reports "UF" for Up, Fallback enabled then you are affected by this issue. Note that the same switch will be the active switch for all LACP fallback-enabled port channels connected to this pair of switches.

These examples show that the switch "X-TOR4B" is the active switch for LACP fallback:

X-TOR4B# show port-channel summary

Flags:  D - Down    I - member up but inactive    P - member up and active
        U - Up (port-channel)    F - Fallback Activated
--------------------------------------------------------------------------------
Group Port-Channel           Type     Protocol  Member Ports
--------------------------------------------------------------------------------
1    port-channel1    (UF)    Eth      DYNAMIC   1/1/5(P)
2    port-channel2    (UF)    Eth      DYNAMIC   1/1/6(P)

X-TOR4A# show port-channel summary

Flags:  D - Down    I - member up but inactive    P - member up and active
        U - Up (port-channel)    F - Fallback Activated
--------------------------------------------------------------------------------
Group Port-Channel           Type     Protocol  Member Ports
--------------------------------------------------------------------------------
1    port-channel1    (D)     Eth      DYNAMIC   1/1/5(I)
2    port-channel2    (D)     Eth      DYNAMIC   1/1/6(I)

The resolution is to swap the cables for the two ports mentioned above so that the first NIC port is connected to the switch with the active interface.

Affected Products

PowerFlex rack, PowerFlex Appliance
Article Properties
Article Number: 000189241
Article Type: Solution
Last Modified: 09 يناير 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.