IDPA: Falha ao criar checkpoint do Protection Software durante a execução de tarefas pós-upgrade
Summary: Durante as tarefas pós-upgrade do 2.7, o Avamar e o Appliance Configuration Manager (ACM) acionam tarefas de manutenção do Avamar, o que pode causar falha em uma delas.
Symptoms
CASE 1: O ACM tenta substituir o agendador de manutenção do Avamar para criar o checkpoint no Avamar. Qualquer atividade de manutenção do Avamar que possa estar em andamento no momento pode ser encerrada devido à substituição.Avamar: failed hfscheck maintenance with error MSG_ERR_KILLED or similar message related to the failure of a maintenance activity is displayed on the Avamar UI Events page.
CASO 2: Se o ACM não puder substituir as atividades de manutenção do Avamar, o seguinte aviso será exibido na página Appliance Upgrade Progress:
Cause
Como parte das tarefas pós-upgrade, o ACM tenta fazer um checkpoint no Avamar. Isso serve para proteger contra a perda de dados que pode ocorrer devido a um desligamento abrupto ou interrupção semelhante. Isso pode resultar em um dos seguintes casos de falha.
CASO 1:
o ACM substitui com êxito o agendador de manutenção do Avamar para criar um checkpoint:
2021-08-13 12:15:55,621 INFO [Thread-118]-avadapter.AvamarUtil: takeAvamarCheckPoint --> Starting to execute:mccli checkpoint create --override_maintenance_scheduler
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Creating session using SSH parameters: Host : [10.198.1.79] User : [admin] Password : [**********]
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Connecting to host [10.198.1.79] using provided credentials.
A substituição do agendador de manutenção interrompe qualquer tarefa de manutenção do Avamar em andamento, como HFSCheck, o que resulta, neste caso, em erro MSG_ERR_KILLED.
CASO 2:
O ACM não consegue substituir o agendador de manutenção do Avamar para criar um checkpoint porque o Avamar já iniciou uma tarefa de checkpoint. Nesse caso, um aviso é exibido na página Appliance Upgrade Progress do ACM da seguinte forma:
Nota: Nesse caso, conecte-se ao servidor Avamar e verifique se um checkpoint mais recente foi criado após a conclusão bem-sucedida do upgrade.
Resolution
RESOLUÇÃO PARA O CASO 1:
A falha das atividades de manutenção acionadas pelo Avamar é um comportamento esperado. Ignore e confirme esse erro na página Avamar AUI Events.
Se o Avamar também relatar um alerta de integridade dos dados devido à falha (eliminação) hfscheck, entre em contato com o suporte e faça referência a isso e KB:000174970.
RESOLUÇÃO PARA O CASO 2:
Conecte-se ao Avamar Server usando SSH com credenciais de administrador e use o seguinte comando para verificar se um checkpoint mais recente foi criado com sucesso:
cplist --full
Certifique-se de que a data e a hora de criação do checkpoint sejam posteriores à conclusão bem-sucedida do upgrade.
Se um checkpoint mais recente (criado após o upgrade ter sido concluído com sucesso) não existir, siga estas etapas para criar manualmente um checkpoint:
- Abra um putty/SSH para a AVE usando as credenciais de administrador.
- Suspenda agendador de manutenção:
dpnctl stop maint - Interrompa o serviço do agendador de backup:
dpnctl stop sched - Verifique se os serviços estão suspensos ou interrompidos:
dpnctl status - Faça um checkpoint:
avmaint checkpoint --ava - Monitore o status do checkpoint e anote o nome dele:
watch avmaint cpstatus - Após a conclusão do
status="completed"eresult="OK", execute a validação do ponto de verificação (verificação HFS) no checkpoint manual:avmaint hfscheck --ava --rolling=true --full=false(verifique se está validando o checkpoint recém-criado). - Quando o comando for concluído, monitore o status da verificação de HFS:
watch avmaint hfscheckstatus - A saída deve ser
status="completed" and result="OK". - Verifique se você tem o CP recém-criado e
HFScheckno AVE:cplist --full