IDPA: Yükseltme sonrası görevler gerçekleştirilirken Protection Software kontrol noktası oluşturulamadı
Summary: 2.7 sonrası yükseltme görevleri sırasında hem Avamar hem de Appliance Configuration Manager (ACM), Avamar bakım görevlerini tetikler ve bu görevlerden biri başarısız olabilir.
Symptoms
DURUM 1: ACM, Avamar'da bir kontrol noktası oluşturmak için Avamar bakım zamanlayıcısını geçersiz kılmaya çalışır. O sırada devam ediyor olabilecek tüm Avamar bakım etkinlikleri, geçersiz kılma nedeniyle sonlandırılabilir.Avamar: failed hfscheck maintenance with error MSG_ERR_KILLED or similar message related to the failure of a maintenance activity is displayed on the Avamar UI Events page.
DURUM 2: ACM, Avamar bakım faaliyetlerini geçersiz kılamazsa Appliance Upgrade Progress sayfasında aşağıdaki uyarı görüntülenir:
Cause
Yükseltme sonrası görevlerin bir parçası olarak ACM, Avamar'da bir kontrol noktası almaya çalışır. Bunun amacı, ani bir kapanma veya benzer bir kesinti nedeniyle meydana gelebilecek veri kaybına karşı koruma sağlamaktır. Bu, aşağıdaki başarısızlık durumlarından birine yol açabilir.
DURUM 1:
ACM, bir kontrol noktası oluşturmak için Avamar bakım zamanlayıcısını başarıyla geçersiz kılar:
2021-08-13 12:15:55,621 INFO [Thread-118]-avadapter.AvamarUtil: takeAvamarCheckPoint --> Starting to execute:mccli checkpoint create --override_maintenance_scheduler
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Creating session using SSH parameters: Host : [10.198.1.79] User : [admin] Password : [**********]
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Connecting to host [10.198.1.79] using provided credentials.
Bakım zamanlayıcısını geçersiz kılmak, aşağıdakiler gibi devam eden tüm Avamar bakım görevlerini durdurur: HFSCheck, bu durumda hataya neden olur MSG_ERR_KILLED.
DURUM 2:
Avamar zaten bir kontrol noktası görevi başlattığı için ACM, bir kontrol noktası oluşturmak için Avamar bakım zamanlayıcısını geçersiz kılmada başarılı olmaz. Bu durumda, ACM Cihazı Yükseltme İlerleme sayfasında aşağıdaki gibi bir uyarı görüntülenir:
NOT: Bu durumda Avamar sunucusuna bağlanın ve yükseltme başarıyla tamamlandıktan sonra en son kontrol noktasının oluşturulduğunu doğrulayın.
Resolution
DURUM 1 IÇIN ÇÖZÜM:
Avamar tarafından tetiklenen bakım işlemlerinin başarısız olması beklenen bir davranıştır. Avamar AUI Events sayfasındaki bu hatayı yok sayın ve onaylayın.
Avamar daha sonra başarısız (sonlandırıldı) nedeniyle bir Veri bütünlüğü Uyarısı da rapor etmelidir. hfscheck, destek ile iletişime geçin ve bu KB:000174970 yi referans gösterin.
DURUM 2 IÇIN ÇÖZÜM:
SSH'yi yönetici kimlik bilgileriyle kullanarak Avamar sunucusuna bağlanın ve en son kontrol noktasının başarıyla oluşturulduğunu doğrulamak için aşağıdaki komutu kullanın:
cplist --full
Kontrol noktası oluşturulma tarihi ve saatinin, yükseltme başarıyla tamamlandıktan sonra olduğundan emin olun.
En son kontrol noktası (yükseltme başarıyla tamamlandıktan sonra oluşturulan) mevcut değilse manuel olarak bir kontrol noktası oluşturmak için aşağıdaki adımları kullanın:
- Yönetici kimlik bilgilerini kullanarak AVE'de bir putty/SSH açın.
- Bakım zamanlayıcısını askıya alma:
dpnctl stop maint - Yedekleme zamanlayıcı hizmetini durdurun:
dpnctl stop sched - Hizmetlerin askıya alındığını veya durdurulduğunu doğrulayın:
dpnctl status - Kontrol noktası alın:
avmaint checkpoint --ava - Kontrol noktası durumunu izleyin ve kontrol noktası adını not edin:
watch avmaint cpstatus - Bir kez
status="completed"veresult="OK", manuel kontrol noktasında kontrol noktası doğrulamasını (HFS kontrolü) çalıştırın:avmaint hfscheck --ava --rolling=true --full=false(yeni oluşturulan kontrol noktasını doğruladığını doğrulayın). - Komut tamamlandığında HFS denetim durumunu izleyin:
watch avmaint hfscheckstatus - Çıktı şu şekilde olmalıdır:
status="completed" and result="OK". - Yeni oluşturduğunuz CP'ye sahip olduğunuzu doğrulayın ve
HFScheckAVE'de:cplist --full