IDPA: Не вдалося створити контрольну точку програмного забезпечення захисту під час виконання завдань після оновлення
Summary: Під час завдань оновлення після версії 2.7 Avamar і Appliance Configuration Manager (ACM) запускають завдання з обслуговування Avamar, що може призвести до відмови одного з них.
Symptoms
ВИПАДОК 1: ACM намагається обійти планувальник технічного обслуговування Avamar, щоб створити контрольний пункт на Avamar. Будь-які заходи з обслуговування Avamar, які можуть тривати на той момент, можуть бути припинені через перевизначення контролю.Avamar: failed hfscheck maintenance with error MSG_ERR_KILLED or similar message related to the failure of a maintenance activity is displayed on the Avamar UI Events page.
ВИПАДОК 2: Якщо ACM не може скасувати дії з обслуговування Avamar, на сторінці прогресу оновлення приладів відображається наступне попередження:
Cause
У рамках завдань після модернізації ACM намагається захопити контрольний пункт на Авамарі. Це потрібно для захисту від втрати даних, які можуть виникнути через раптове вимкнення або подібні порушення. Це може призвести до одного з наступних випадків відмови.
ВИПАДОК1:
ACM успішно обіймає планувальник обслуговування Avamar, щоб створити контрольну точку:
2021-08-13 12:15:55,621 INFO [Thread-118]-avadapter.AvamarUtil: takeAvamarCheckPoint --> Starting to execute:mccli checkpoint create --override_maintenance_scheduler
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Creating session using SSH parameters: Host : [10.198.1.79] User : [admin] Password : [**********]
2021-08-13 12:15:55,621 INFO [Thread-118]-util.SSHUtil: Connecting to host [10.198.1.79] using provided credentials.
Перевизначення планувальника технічного обслуговування зупиняє будь-які завдання з обслуговування Avamar у процесі, наприклад HFSCheck, що в цьому випадку призводить до помилки MSG_ERR_KILLED.
ВИПАДОК 2:
ACM не вдається обійти планувальник обслуговування Avamar, щоб створити контрольну точку, оскільки Avamar вже розпочав завдання з контрольною точкою. У цьому випадку на сторінці прогресу оновлення ACM Appliance відображається попередження наступним чином:
ПРИМІТКА. У такому випадку підключіться до сервера Avamar і переконайтеся, що після успішного оновлення створено останню контрольну точку.
Resolution
ВИРІШЕННЯ СПРАВИ 1:
Очікувана поведінка відмови від технічного обслуговування, спричиненого Avamar. Ігноруйте та визнайте цю помилку на сторінці подій Avamar AUI.
Якщо Avamar також повідомить про попередження про цілісність даних через невдалий (вбитий) hfscheck, зв'яжіться зі службою підтримки та посилайтеся на це та на KB:000174970.
РОЗВ'ЯЗАННЯ ДЛЯ СПРАВИ 2:
Підключіться до сервера Avamar за допомогою SSH з адміністративними обліковими даними та скористайтеся наступною командою, щоб перевірити, що остання контрольна точка успішно створена:
cplist --full
Переконайтеся, що дата і час створення контрольної точки припадають на успішне завершення оновлення.
Якщо остання контрольна точка (створена після успішного завершення оновлення) не існує, виконуйте наступні кроки для ручного створення контрольної точки:
- Відкрийте пластилін/SSH у AVE, використовуючи адміністративні облікові дані.
- Графік припинення обслуговування:
dpnctl stop maint - Припиніть службу резервного планувальника:
dpnctl stop sched - Перевірте, чи призупинено або зупинено ці послуги:
dpnctl status - Візьміть контрольну точку:
avmaint checkpoint --ava - Слідкуйте за станом контрольно-пропускної точки та запам'ятовуйте назву контрольно-пропускної точки:
watch avmaint cpstatus - Колись
status="completed"іresult="OK", запусти перевірку контрольної точки (HFS-перевірку) на ручній контрольній точці:avmaint hfscheck --ava --rolling=true --full=false(перевірте, що це перевірка новоствореної контрольної точки). - Після виконання команди слідкуйте за статусом перевірки HFS:
watch avmaint hfscheckstatus - Вихід має бути
status="completed" and result="OK". - Переконайтеся, що у вас є новостворений CP, і
HFScheckна AVE:cplist --full