NetWorker NVP-vProxy: Image recovery is marked as successful but the VM cannot start due to missing disk

Summary: When recovering a VM using vProxy - Image Recovery - the recovery is marked as successfully completed but the VM is unable to power on due to a missing disk.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VMware reports a missing disk when it attempts to power on a recovered VM:
File "VM_name_#.vmdk" was not found Failed to start the virtual machine. Module Disk power on failed. Cannot open the disk 'VM_name_#.vmdk' or one of the snapshot disks it depends on. The system cannot find the file specified VMware ESX cannot find the virtual disk "VM_name_#.vmdk". Verify the path is valid and try again.

Cause

It is possible the vProxy was migrated during the recovery by VMware SDRS.  The vProxy VM's vmware.log (found in the vProxy VMs datastore location) will report that a migration occurred during the same time frame as the VM restore. You can also review the VMware Tasks and Events to see if the migration was logged.

When a VM is migrated, it takes ownership of the disks attached to it. During a recover operation the VM disks are attached to the vProxy appliance; meaning, if the vProxy VM is migrated during a restore operation it takes ownership of the VM's disks.

Resolution

If the ESXi cluster is using DRS/SDRS, set an exclusion for the vProxies.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000191829
Article Type: Solution
Last Modified: 14 يناير 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.