CloudLink. Агент CloudLink не отвечает из-за утечки памяти.
Summary: Сбой CloudLink из-за утечки памяти, обнаруженной в 7.1.1 и 7.1.2. Клиенты KMIP не затрагиваются.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Агент будет отключен от CLC из-за утечки памяти. Во время этого невозможно выполнять такие действия администратора, как добавление новых дисков, удаление дисков и замена ключей, так как агент отключен. Операции ввода-вывода не будут затронуты, так как диски уже имеют ключи.
Журналы ОС:
Журналы нескольких сеансов показывают, что сеанс агента закрылся после сбоя службы:
Журналы ОС:
Linux.
После сбоя службы svmd в Linux запись в /var/log отображается в RHEL или CentOS с ошибкой нехватки памяти.
После сбоя службы svmd в Linux запись в /var/log отображается в RHEL или CentOS с ошибкой нехватки памяти.
Windows.
В случае Windows любой сбой будет зарегистрирован в журналах средства просмотра событий Windows. Служба может автоматически запускаться в Windows с настройками восстановления по умолчанию, поэтому агент попытается восстановить соединение с сервером CloudLink.
В случае Windows любой сбой будет зарегистрирован в журналах средства просмотра событий Windows. Служба может автоматически запускаться в Windows с настройками восстановления по умолчанию, поэтому агент попытается восстановить соединение с сервером CloudLink.
В пользовательском веб-интерфейсе CloudLink Center агент показывает сообщение об отключении после сбоя службы:
Журналы нескольких сеансов показывают, что сеанс агента закрылся после сбоя службы:
Cause
Для обеспечения комплаенса в области безопасности средство CloudLink модернизировало библиотеку TLS стороннего производителя, используемую в агенте, до последней версии. Новая версия библиотеки изменила процесс обмена сообщениями, что приводит к выделению памяти в коде агента в цикле.
Resolution
Решение.
Для повторного запуска службы требуется перезапустить службу агента CloudLink.
Окончательное решение.
Эта проблема устранена в CloudLink 7.1.3.
Для повторного запуска службы требуется перезапустить службу агента CloudLink.
- В Linux: После сбоя службу агента можно перезапустить вручную. Потеря данных отсутствует, так как зашифрованный диск остается зашифрованным. Команда для перезапуска службы агента: service svmd restart.
- В Windows: После сбоя Windows автоматически перезапустит службу, если настройки восстановления службы установлены на перезапуск службы (по умолчанию). Потеря данных отсутствует, так как зашифрованный диск остается зашифрованным.
Окончательное решение.
Эта проблема устранена в CloudLink 7.1.3.
Additional Information
ОС Linux.
Например, в системе с 2 Гбайт памяти сбой службы агента происходил через 5 дней, когда потребление памяти увеличивалось примерно до 1,6 Гбайт, при этом средняя утечка составляла 300 Мбайт в день.
ОС Windows.
Например, в системе с 4 Гбайт памяти потребление памяти службой агента увеличивается и достигает 1,9 Гбайт. Предполагается, что сбой происходит, когда потребление достигает примерно 3 Гбайт при средней утечке 400 Мбайт в день.
Например, в системе с 2 Гбайт памяти сбой службы агента происходил через 5 дней, когда потребление памяти увеличивалось примерно до 1,6 Гбайт, при этом средняя утечка составляла 300 Мбайт в день.
ОС Windows.
Например, в системе с 4 Гбайт памяти потребление памяти службой агента увеличивается и достигает 1,9 Гбайт. Предполагается, что сбой происходит, когда потребление достигает примерно 3 Гбайт при средней утечке 400 Мбайт в день.
Affected Products
CloudLink SecureVM, CloudLinkArticle Properties
Article Number: 000197219
Article Type: Solution
Last Modified: 13 مايو 2026
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.