Avamar: A scheduled backup does not run as a backup group within it containing no members

Summary: Scheduled backups do not run because a backup group within it no longer contains members.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A scheduled Backup Policy that used to run, no longer runs at the scheduled time.

Cause

This is caused by a backup group within the schedule no longer containing members.

Follow the steps below to check if the scheduled Backup Policy is no longer running:

 

  1. Log in to the Avamar Utility Node as admin.

  1. Change to the Management Console Server log directory: 

cd /usr/local/avamar/var/mc/server_log/
 
  1. Run the following command:

    for f in mcserver.log.*; do grep -H "schedName" $f && echo && echo "################################" && echo; done
 

Example output:

mcserver.log.11:
<deleted non-essential info>
SchedID=S1111111111111 schedName=BU_REP_STD11 version=null allowOvertime=true overtimeOption=NEXT_SUCCESS endTime=1665088200000  />

################################
mcserver.log.12:
<deleted non-essential info>
SchedID=S2222222222222 schedName=BU_VM_CLIENTS_STD1_0100-1700_16HRS version=null allowOvertime=true overtimeOption=NEXT_SUCCESS endTime=1665100800000 />

################################

 

In the example above, assume that the backup policy that is not running is called "3_pm".

The command shows other scheduled Backup Policy names, but not the "schedName=3_pm" that is expected to be found.

In this instance, the backup policy "3_pm" contained several Groups. 
        • One of these groups contains no members. 
        • This empty group used to contain multiple Virtual Machine clients.
        • The customer had gradually retired and removed the clients from the vCenter, and the group became empty.

Avamar does not flag if a group is empty, and the process to run the scheduled 3_pm Backup Policy prevented the schedule from running.

Resolution

1. Identify which scheduled Backup Policy is no longer running. 

2. Check if the backup policy contains multiple groups, and no Group is empty.
  • If an empty Group is found, remove the empty Group from the Backup Policy.

3. Run a manual backup, or allow the backup policy to run as scheduled.

4. In the /usr/local/avamar/var/mc/server_log/ directory, run the following command, to search for the schedule name (schedName) in the mcserver.log.0 log file to see if the Backup Policy name is found.  

grep "schedName" mcserver.log.0
 

5. If the Backup Policy schedName is NOT found, contact Dell Support.

Note: If the backup was run per schedule, additional logs may require searching:
 
grep "schedName" mcserver.log.?
grep "schedName" mcserver.log.*

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000210062
Article Type: Solution
Last Modified: 27 مايو 2026
Version:  8
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