ECS: Internal Fabric Log Rotation Issues
Summary: This KB explains the causes of potential issues related to internal log rotation, and the recommended versions to upgrade to.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
In rare cases, rootFS may start filling up due to numerous logs being created on an impacted node.
Cause
Log rotation for internal Fabric logs that are small in size may not work as expected, causing these logs to accumulate on the node.
Resolution
- ECS Engineering has implemented a fix to address these potential log rotation issues
- FABRIC-9928/FABRIC-10023: Fix potential uncontrollable growth of fabric agent logs, which avoids data unavailability caused by
rootFSrunning full.
- FABRIC-9928/FABRIC-10023: Fix potential uncontrollable growth of fabric agent logs, which avoids data unavailability caused by
- It is recommended to upgrade to a code version which includes these log rotation fixes:
- For ECS 3.8.0.x:
- ECS 3.8.0.3 General Availability (GA) and above for the rest of the 3.8.0.x family.
- ECS 3.8.0.2 General Patch 2 (GP2) and newer GPs.
- For ECS 3.7.0.x:
- ECS 3.7.0.6 General Patch 1 (GP1) and above for the rest of the 3.7.0.x family
- ECS 3.7.0.6 General Patch 1 (GP1) and above for the rest of the 3.7.0.x family
- For ECS 3.8.0.x:
Affected Products
ECS, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, ECS Software, Elastic Cloud StorageArticle Properties
Article Number: 000214360
Article Type: Solution
Last Modified: 05 فبراير 2026
Version: 9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.