NVP vProxy: Não foi possível fazer login usando credenciais root, acesso root perdido

Summary: O acesso à conta root por meio do equipamento vProxy foi perdido.

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Symptoms

No VMware vSphere Web Client, não é possível fazer log-in no equipamento vProxy usando a conta root. Erros de acesso negado ou credenciais inválidas são retornadas.
 
Nota: O acesso root é bloqueado por SSH por padrão. A menos que as definições do arquivo de configuração SSH no vProxy estejam definidas para habilitar root por SSH, o acesso root retorna "Access Denied" por SSH. A conta root pode ser acessada por meio da conexão do console do vSphere Virtual Machine (VM).

Você não pode fazer log-in usando a conta de administrador do vProxy no SSH ou no vSphere Web Client. Erros de credencial inválida ou acesso negado são exibidos.

Cause

A conta root e os usuários admin são bloqueados ou as credenciais do usuário são perdidas ou desconhecidas.

Resolution

Nota: Se o acesso à conta de usuário root e admin for perdido, consulte o seguinte artigo: NVP - vProxy: Como atualizar ou alterar a senha de administrador ou root do vProxy. Este artigo fornece instruções para redefinir a senha da conta root no modo de usuário único.

 

Se a conta root estiver acessível:
Se a conta root puder ser acessada por meio da conexão do console da VM do vSphere, conecte-se ao vProxy via SSH e faça log-in com as credenciais de administrador. Alterne para a conta de usuário root usando o comando abaixo e especifique a senha do usuário root.

sudo su -

Você só poderá alterar (atualizar) a senha root se já tiver acesso à conta root.

sudo passwd root

Se a senha do usuário admin tiver sido perdida, mas você souber a senha root, conecte-se ao vProxy pelo vSphere Web Client e faça login como root. A senha de administrador pode ser alterada com o comando:

passwd admin
Nota: Se você alterar a senha do usuário admin, deverá atualizar a senha do vProxy no NetWorker. Caso contrário, ele continua tentando usar a senha antiga e bloqueia a conta. Isso pode ser feito no NetWorker Management Console (NMC) ou no NetWorker Web User Interface (NWUI).
 Propriedades do vProxy no NetWorker Management Console   
Figura 1: Captura de tela das propriedades do vProxy do NetWorker Management Console (NMC).
Propriedades do vProxy na interface do usuário da Web do NetWorker
Figura 2: Captura de tela das propriedades do vProxy da interface do usuário da Web do NetWorker (NWUI).

Se a conta de administrador estiver bloqueada, faça log-in com a conta root no vSphere Web Client e redefina a conta de administrador com pam_tally2 Para redefini-lo:

pam_tally2 --user admin --reset

Se a conta de administrador continuar bloqueada, verifique de onde vêm as solicitações de login:

journalctl -u sshd | grep -w 'Failed password'

Este comando lista os endereços IP dos sistemas que tentaram (e falharam) fazer login usando as credenciais de administrador:

Dec 06 09:23:36 nsr-vproxy02.amer.lan sshd[9407]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.9.100  user=admin
Dec 06 09:23:38 nsr-vproxy02.amer.lan sshd[9407]: Failed password for admin from 192.168.9.100 port 54788 ssh2

No exemplo acima, podemos ver que alguém tentou fazer log-in como administrador usando SSH do host 192.168.9.100. Podem aplicar-se as seguintes condições:

  • O host é um servidor NetWorker com a senha incorreta do vProxy definida nas propriedades do vProxy
  • Há uma ferramenta ou script automatizado configurado com as credenciais incorretas (isso estaria fora do NetWorker).
  • Um usuário continua tentando acessar o vProxy usando as credenciais incorretas e bloqueando a conta.
Nota: O endereço mostrado não conta para configurações de conversão de endereços de rede (NAT). Se o NAT ou o encaminhamento de porta for usado para redirecionar o tráfego SSH para o vProxy, o journalctl A saída mostra o endereço de destino NAT como a origem, não de onde a sessão SSH se originou.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000215827
Article Type: Solution
Last Modified: 03 فبراير 2026
Version:  8
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