Openshift Event Code: 1038NODE0003
Summary: Node is unreachable.
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Symptoms
The performance of the cluster deployments is affected, depending on the overall workload and the type of the node.
Cause
Kubernetes node is unreachable and some workloads may be rescheduled.
Resolution
Diagnosis
The notification details should list the node that’s not reachable. For Example:
- alertname = KubeNodeUnreachable ... - node = node1.example.com ... |
Login to the cluster. Check the status of that node:
$ kubectl get node $NODE -o yaml |
The output should describe why the node is not reachable.
Common failure scenarios:
- disruptive software upgrades
- network patitioning due to hardware failures
- firewall rules
- virtual machines suspended due to storage area network problems
- system crashes / freezes due to software or hardware malfunctions
Mitigation
In case of maintenance ensure to cordon and drain node.
In other cases ensure storage and networking redundancy if applicable.
See KubeNode See node problem detector See Watchdog timer
Support
If all the above steps cannot resolve the issue, contact the Dell EMC technical support for further investigation.
Affected Products
APEX Cloud Platform for Red Hat OpenShiftArticle Properties
Article Number: 000217419
Article Type: Solution
Last Modified: 20 فبراير 2026
Version: 3
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