PowerEdge: Trusted Platform Module (TPM) Secure Bootin ja ESXi:n vianmääritys

Summary: Tämä tietämyskannan artikkeli sisältää yksityiskohtaisen oppaan Trusted Platform Module (TPM) 2.0-, Secure Boot- ja ESXi-ongelmien vianmääritykseen Dell-palvelimissa. Se tarjoaa vaiheittaiset ohjeet yleisten ongelmien ratkaisemiseksi ja varmistaa palvelimen moitteettoman toiminnan ja turvallisuuden. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Isännän tila Todistus-sarakkeessa näkyy "Host Secure Boot was disabled"
  • Trusted Platform Module (TPM) 2.0 -laite havaittu, mutta yhteyttä ei voi muodostaa
  • Isännän tila Todistus-sarakkeessa näkyy "N/A"
  • Kun ESXi-isännässä käytetään TPM 2.0 (Trusted Platform Module) -laitetta, isäntä ei läpäise vahvistusvaihetta
  • Virheilmoitus on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa"

Cause

Suojatun käynnistyksen ja TPM-ongelmien syitä ovat pois käytöstä poistettu suojattu käynnistys, väärin määritetty BIOS, laitteistoyhteensopivuus, viallinen TPM 2.0 -moduuli ja TPM-asetukset.

Resolution

TPM:n ja suojatun käynnistyksen ongelmien vianmääritys Dell-palvelimissa

Sisällysluettelo:

Johdanto
Edellytykset
TPM:n ja suojatun käynnistyksen ongelmien
vianmääritysTodistusongelmien
vianmääritysTPM-hierarkian ottaminen käyttöön


Johdanto

Tämä tietämyskannan artikkeli sisältää vaiheittaiset ohjeet TPM (Trusted Platform Module)- ja Secure Boot -turvapiiriin liittyvien yleisten ongelmien vianmääritykseen ja ratkaisemiseen Dell-palvelimissa. Nämä ongelmat voivat haitata oikeanlaista todentamista ja järjestelmän toimintaa. Varmista Dell-palvelimen optimaalinen suorituskyky tämän asiakirjan ohjeiden mukaisesti.


Edellytykset

  • Varmista, että iDRAC havaitsee TPM 2.0 -laitteen ja toimii sen toiminnassa.
  • Varmista, että UEFI, TPM ja Secure Boot ovat käytössä.
  • Käytä TPM 2.0 -algoritmia "SHA256", ota Intel TXT käyttöön 

Tarkat tiedot ja vianmääritysohjeet ongelmaan "TPM 2.0 -laite havaittu, mutta yhteyttä ei voida muodostaa" on artikkelissa 000193231 saatavilla täältä:

PowerEdge: ESXi 7.0 TPM 2.0 -laitteen virhe havaittu, mutta yhteyttä ei voida muodostaa
 


TPM:n ja suojatun käynnistyksen ongelmien vianmääritys

Suojatun käynnistyksen ottaminen käyttöön

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys vCenter Serveriin vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeesta.
  6. Jos virhesanoma on "Isännän suojattu käynnistys oli poistettu käytöstä", ratkaise ongelma seuraavasti:
    • Tarkista, voiko Secure Bootin ottaa käyttöön. Jos sitä ei voi ottaa käyttöön, ota yhteys Dellin tekniseen tukeen.
    • Voit ottaa suojatun käynnistyksen käyttöön seuraavasti:
      • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
      • Kirjaudu iDRACiin Secure Bootin määritystä varten ja valitse Määritä-välilehti > BIOS Settings > System Security > TPM Advanced Settings.
      • Valitse Secure Boot "enable" ja napsauta Apply>OK>Apply and Reboot.
      • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
      • Kirjaudu VMware vCenter vSphere Clientiin ja aseta solmu poistumaan huoltotilasta.
    • Suorita vaihe 6 jokaisessa solmussa, kunnes suojattu käynnistys on otettu käyttöön iDRACissa.
    • Kirjaudu VMware vCenter vSphere Clientiin ja valitse konesali.
    • Valitse Näyttö-välilehti > Suojaus ja varmista, että viimeisimmän todistuksen tila on Hyväksytty.
    • Jos näet hälytyksen, jossa on punainen kuvake, valitse se ja napsauta PALAUTA VIHREÄKSI.

TPM:n ja suojatun käynnistyksen ottaminen käyttöön

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys VMware vCenter Serveriin VMware vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeesta.
  6. Jos virhesanoma on "N/A", sinun on otettava TPM ja Secure Boot käyttöön, jotta ongelma voidaan ratkaista.
    • Tarkista, voiko Secure Bootin ottaa käyttöön. Jos sitä ei voi ottaa käyttöön, ota yhteys Dellin tekniseen tukeen.
    • Ota TPM ja Secure Boot käyttöön seuraavasti:
      • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
      • Kirjaudu iDRACiin Secure Bootin määrittämistä varten ja valitse Määritä-välilehti > BIOS-asetukset > System Security > TPM Security "On" TPM > Advanced Settings.
      • Valitse Secure Boot "enable" ja napsauta Apply>OK>Apply and Reboot.
      • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
      • Siirry Dashboard > Virtual Consoleen ja tarkista, näkyykö konsolissa "successfully completed". Jos kyllä, jatka.
      • Kirjaudu VMware vCenter vSphere Clientiin ja irrota solmu.
      • Yhdistä solmu uudelleen ja poistu sitten huoltotilasta.
    • Suorita vaiheet 6 kussakin solmussa, kunnes kaikissa solmuissa TPM ja Secure Boot on otettu käyttöön iDRACissa.
    • Kirjaudu VMware vCenter vSphere Clientiin ja siirry konesaliin.
    • Valitse Näyttö-välilehti>Suojaus ja vahvista, että viimeisimmän vahvistusviestin tilaksi on "Hyväksytty".
    • Jos näet hälytyksen, jossa on punainen kuvake, valitse tietty laukaistu hälytys ja napsauta PALAUTA VIHREÄKSI.

Isännän vahvistusongelmat

Kun TPM 2.0 -laitetta käytetään ESXi-isännässä, sen todennus ilman tarkkoja vSphere-asiakastietoja saattaa epäonnistua. Voit tehdä ongelman vianmäärityksen seuraavasti:

  1. Siirry konesaliin ja valitse Näyttö-välilehti .
  2. Valitse Turvallisuus.
  3. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeessa.

Nyt voit tunnistaa ratkaisun kohtaamastasi virheilmoituksesta riippuen:

  • Jos virhesanoma on Host Secure Boot was disabled, korjaa ongelma kohdasta Suojatun käynnistyksen ottaminen käyttöön. Varmista ensin, että suojattu käynnistys toimii.
  • Jos isännän todistuksen tila epäonnistuu, tarkista vCenter Server -lokista seuraava viesti: "Ei välimuistissa olevaa identiteettiavainta, ladataan DB: stä." Tämä ilmoitus ilmaisee, että olet lisäämässä TPM 2.0 -sirua vCenter Serverin jo hallitsemaan ESXi-isäntään. Katkaise ensin isännän yhteys ja liitä se sitten uudelleen.

Hierarkian ottaminen käyttöön

Jos virhesanoma on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa", sinun on otettava TPM-hierarkia käyttöön ongelman ratkaisemiseksi. Ota TPM-hierarkia käyttöön seuraavasti:

  1. Tarkastele ESXi-isännän hälytyksen tilaa ja siihen liittyvää virheilmoitusta.
  2. Muodosta yhteys VMware vCenter Serveriin VMware vSphere Clientilla.
  3. Valitse konesali ja napsauta Näyttö-välilehteä.
  4. Valitse Turvallisuus.
  5. Tarkista isännän tila Todistus-sarakkeessa ja lue siihen liittyvä viesti Viesti-sarakkeessa.
  6. Jos virhesanoma on "Hyväksymisavainta ei voi provisioida TPM 2.0 -laitteessa: Tukiavaimen luonti epäonnistui laitteessa", sinun on otettava TPM-hierarkia käyttöön ongelman ratkaisemiseksi.
  7. Jos näet hälytyksen, jossa on punainen kuvake, valitse tietty laukaistu hälytys ja napsauta PALAUTA VIHREÄKSI.
  8. Ota TPM-hierarkia käyttöön seuraavasti:
    • Siirrä yksi solmu VMware vCenter vSphere Clientissa huoltotilaan.
    • Määritä suojattu käynnistys kirjautumalla iDRACiin ja valitsemalla Määritä-välilehti > BIOS-asetukset > Järjestelmän suojaus > TPM.
    • Valitse TPM-hierarkia Enable ja valitse Apply>OK>, Apply andReboot.
    • Valitse Työjono. Odota, että kaikki työt valmistuvat 100-prosenttisesti.
    • Siirry Dashboard > Virtual Consoleen ja tarkista, näkyykö konsolissa "successfully completed". Jos kyllä, jatka.
    • Kirjaudu VMware vCenter vSphere Clientiin ja valitse Exit Maintenance Mode.
  9. Suorita vaiheet 7 ja 8 kussakin solmussa, kunnes TPM-hierarkia on otettu käyttöön kaikissa solmuissa iDRACissa.
  10. Kirjaudu VMware vCenter vSphere Clientiin ja valitse konesali.
  11. Valitse Näyttö-välilehti>Suojaus ja vahvista, että viimeisimmän vahvistusviestin tilaksi on "Hyväksytty".
Huomautus: VMware QuickBootia ei tueta, kun Secure Boot on käytössä.

Ota meihin yhteyttä, jos vianmääritysvaiheet eivät ratkaisseet ongelmaa. 

Affected Products

Dell EMC vSAN Ready Nodes, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, VxFlex Ready Node , VxFlex Ready Node R640, VxFlex Ready Node R740xd, VMware ESXi 7.x, VMware ESXi 8.x, VMware ESXi 9.x, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840, VxFlex Ready Node R840 ...
Article Properties
Article Number: 000218542
Article Type: Solution
Last Modified: 05 فبراير 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.