ECS : OBS: Bucket Deletion Failed
Summary: Alerte d’échec de la suppression simplifiée des buckets. Alerte - ID du symptôme : 15000
Symptoms
ID d’événement/symptôme : 15000
La chaîne d’événement s’affiche dans l’interface utilisateur et dans l’appel à distance :
Background bucket deletion failed for <bucket-id>. Deleted <entriesDeleted> FailedDueToRetention <failedToDeleteRetention> FailedDueToDangling <failedToDeleteDangling> FailedDueToOther <failedToDeleteOther>
L’interface utilisateur de gestion des buckets ECS peut afficher les détails de l’échec de suppression du bucket.
Cause
L’alerte est déclenchée en cas d’échec de la tâche de suppression du bucket.
Les suppressions de buckets peuvent échouer pour plusieurs raisons. Certaines des raisons les plus courantes sont la rétention d’objets et les entrées LS pendantes.
Resolution
L’état de la tâche peut être FAILED ou ABORTED : (l’état est codé dans la chaîne d’alerte)
Si la tâche est ABORTED, cela signifie qu’elle est annulée par l’utilisateur en raison d’une volonté d’arrêt ou par ECS en raison d’un état non pris en charge tel qu’une PSO. Si nécessaire, demandez à l’utilisateur de réessayer la tâche de suppression du bucket lorsque ECS revient à l’état normal.
Si la tâche indique ÉCHEC, l’état de la tâche contient des statistiques liées aux raisons de l’échec :
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> failed_to_delete_due_to_retention 0 indique que le bucket contient du contenu sous rétention ou verrouillage d’objet. Ce contenu ne peut pas être supprimé par la fonction de suppression de bucket et risque d’entraîner l’échec de la suppression globale. Une nouvelle tentative ne résoudra pas ces échecs. Indiquez à l’utilisateur que la suppression du bucket ne peut pas supprimer ces objets tant que la rétention n’expire pas ou que la rétention n’est pas supprimée.
Certaines causes de rétention peuvent être contournées, tandis que d’autres ne le peuvent pas- La rétention au niveau du compartiment peut être contournée une fois la suppression en échec
. Une fois la suppression en échec, accédez à l’interface utilisateur de gestion des compartiments pour supprimer ou réduire la rétention
(Dashboard >>Manage >>Buckets >> Choisir un espace >> de nommage Modifier le bucket sélectionné)
(Cliquez sur 'Suivant' dans les deux premières fenêtres, recherchez et définissez la rétention en bas de la page avant d’enregistrer, et réessayez la suppression)
- Le verrouillage d’objet doit être supprimé par l’application ou expirer
- La rétention au niveau objet peut être contournée à l’aide de l’opération de suppression privilégiée à partir de l’application, en s’attendant à ce que le bucket et l’espace de nommage ne soient pas Conformité activée. La rétention d’objet ne peut pas être modifiée dans un espace de nommage conforme
- La rétention au niveau du compartiment peut être contournée une fois la suppression en échec
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> failed_to_delete_due_to_other 0 indique que la suppression du bucket a rencontré une erreur transitoire et que certains contenus n’ont pas pu être supprimés. Réessayer l’opération de suppression du compartiment permet de faire disparaître ces échecs. Une exception particulière pour cet échec est le cas de gestion de la mise à niveau lorsque la tâche est initialement créée dans la version 3.8 et qu’ECS est mis à niveau vers la version 3.8.1. Une telle tâche peut contenir des échecs dus à l’autorisation qui seront convertis en failed_to_delete_due_to_other dans la réponse. Une nouvelle tentative avec la même autorisation utilisateur fait échouer l’opération de suppression du bucket dans la version 3.8.1, car nous disposons d’un modèle d’évaluation des autorisations différent.
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Si plusieurs tentatives ont été effectuées, si la tâche contient toujours des erreurs récupérables et si l’utilisateur ne peut pas supprimer l’objet ou la version à plusieurs reprises, ou encore annuler le MPU via S3, contactez le support technique Dell pour obtenir de l’aide.