ECS: OBS: Bucket verwijderen mislukt

Summary: Waarschuwing voor een fout van vereenvoudigde bucketverwijdering. Alert - Symptoom-ID: 15000

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ID gebeurtenis/symptoom: 15000
De gebeurtenisreeks is te zien in de gebruikersinterface en in de dial home:

Background bucket deletion failed for <bucket-id>. Deleted <entriesDeleted> FailedDueToRetention <failedToDeleteRetention> FailedDueToDangling <failedToDeleteDangling> FailedDueToOther <failedToDeleteOther>

De gebruikersinterface voor ECS-bucketbeheer kan details weergeven van een fout bij het verwijderen van buckets.

Cause

Er wordt een melding verstuurd als de bucketverwijderingstaak is mislukt.
Bucketverwijderingen kunnen om verschillende redenen mislukken.  Enkele van de meest voorkomende redenen zijn objectretentie en bungelende LS-items.

Resolution

De status van de taak kan MISLUKT of AFGEBROKEN zijn: (de status is gecodeerd in de waarschuwingsreeks)

Als de taak wordt AFGEBROKEN, betekent dit dat de taak wordt geannuleerd door de gebruiker vanwege de bereidheid om te stoppen of door de ECS vanwege een niet-ondersteunde status zoals PSO. Vraag de gebruiker indien nodig om de bucketverwijderingstaak opnieuw uit te voeren wanneer de ECS weer normaal is.

Als de taak mislukt is, bevat de taakstatus statistieken met betrekking tot redenen voor mislukkingen:

  • > failed_to_delete_due_to_retention 0 geeft aan dat de bucket inhoud bevat die wordt bewaard of vergrendeld. Deze inhoud kan niet worden verwijderd door de functie voor het verwijderen van buckets en zal er naar verwachting toe leiden dat de algehele verwijdering mislukt. Opnieuw proberen zal deze fouten niet oplossen. Instrueer de gebruiker dat de bucket deze objecten niet kan verwijderen, tenzij de retentie verloopt of de retentie wordt verwijderd.
    Sommige retentieoorzaken kunnen worden omzeild, terwijl andere dat niet kunnen

    • Retentie op bucketniveau kan worden omzeild zodra de verwijdering mislukt
      Zodra de verwijdering mislukt, navigeert u naar de gebruikersinterface voor bucketbeheer om de retentie
      te verwijderen of te verminderen (Dashboard >>Buckets beheren >> Kies een namespace >> Bewerk de geselecteerde bucket)

      Gebruikersinterface bucketbeheer (Klik op 'Volgende' in de eerste twee vensters>>, zoek de retentie onderaan de pagina en stel deze in voordat u opslaat, en probeer het opnieuw te verwijderen) 
      Scherm Bucker-retentieperiode 
    • Objectvergrendeling moet door de applicatie worden verwijderd of verlopen
    • Retentie op objectniveau kan worden omzeild met behulp van de bewerking Privileged Delete van de applicatie, met de verwachting dat de bucket en namespace niet Compliance Enabled zijn.  Objectretentie kan niet worden gewijzigd binnen een compatibele namespace
  • > failed_to_delete_due_to_other 0 geeft aan dat er een tijdelijke fout is opgetreden bij het verwijderen van de bucket en dat bepaalde inhoud niet kan worden verwijderd. Probeer de bucket opnieuw te verwijderen om deze fouten te verhelpen. Een speciale uitzondering voor deze fout is de upgradeafhandeling wanneer de taak in eerste instantie wordt gemaakt in 3.8 en de ECS wordt geüpgraded naar 3.8.1. Een dergelijke taak kan fouten bevatten als gevolg van toestemming die wordt omgezet in failed_to_delete_due_to_other in het antwoord. Een nieuwe poging met dezelfde gebruikersmachtiging mislukt de bucketverwijderingsbewerking in 3.8.1 omdat we een ander evaluatiemodel voor machtigingen hebben.

  • Als er meerdere keren is geprobeerd het opnieuw te proberen en de taak nog steeds herstelbare fouten bevat en de gebruiker herhaaldelijk het object of de versie niet kan verwijderen of de MPU niet kan annuleren via S3, neemt u contact op met de technische support van Dell voor verdere hulp.

Affected Products

ECS, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Article Properties
Article Number: 000223077
Article Type: Solution
Last Modified: 17 ديسمبر 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.