PowerStore: PowerStore Manager UI is unresponsive after third party certificate import

Summary: PowerStore Manager UI is unresponsive after third party certificate import.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After the server certificate is reset or a third-party certificate is imported, the UI may be unresponsive:
image.png

Cause

When the signing CA of the PowerStore server certificate is not present in the user's local trust store, opening the browser prompts the user to accept the risk associated with an unknown CA. If the server certificate is not reset or a third-party certificate is not imported into PowerStore, the browser/UI cannot prompt the user to accept exceptions when trying to establish a new connection to the backend. This results in an unknown CA error, which causes the UI to malfunction.

Resolution

By adding the third-party signing CA to the user’s local trust store before starting the importing process or by adding PowerStore signing CA before resetting the server cert, users avoid this problem.
  1. Save the CA as .crt file
image.png
  1. Add the CA to the trust store (Chrome, Edge, and Firefox)
Option 1. For Chrome, Edge and other browsers except Firefox, we could add CA to user's local trust store
  1. Type "certmgr.msc" in the Start menu Search field, and then press Enter, and expand Trusted Root Certification Authorities, and then select Certificate.image.png
  2. Right-click on the empty space, and then select All tasks > Import. image.png
  3. Click Next in the Certificate Import Wizard window and click Browse and select the CA that you want to import.   image.png
  4. Click Next, select the Place all certificates in the following store option to store the CA securely, then click Browse, and then select Trust Root Certification Authorities as certificate store.   image.png
  5. Click Next, and then Finish to import the certificate. The Certificate Import Wizard shows that "The import was successful."  
image.png

Option 2: For Firefox, we could add CA to Firefox's trust store.
  1.  Click the Firefox menu, select Settings, then click Privacy & Security.  image.png
  2.  Scroll down to the Security section and click View Certificatesimage.png
  3. On the tab Authorities, select Import and select the CA that you want to import.  image.png
  4. Select Trust this CA to identify websites and click OK.  image.png
  5. The CA is in Firefox's trust store now.image.png
 
  1. After import the CA, the browser should be closed and reopened. The UI should be recovered now.

Affected Products

PowerStore
Article Properties
Article Number: 000227174
Article Type: Solution
Last Modified: 14 يونيو 2025
Version:  3
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