Deployment or Upgrading of PowerProtect Data Manager Reporting Engine to 19.17 Reporting Engine may fail

Summary: Deployment or Upgrading of PowerProtect Data Manager Reporting Engine to 19.17 Reporting Engine may fail.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When deploying a new Reporting Engine or upgrading a Reporting Engine to 19.17, the deployment\upgrade will fail if the Reporting Node has been setup with 3 DNS entries.
 

The following error will be logged for the failed deployment\upgrade:

Node configuration failed.
Failed to start the report service.


The following errors are found in the reporting-service.log:

2024-08-09T14:13:27.875Z INFO [PID_IS_UNDEFINED] [main] [c.e.a.common.util.Util.isCertsConfigured(44)] -  Is certificates configured  false  

2024-08-09T14:13:27.875Z ERROR [PID_IS_UNDEFINED] [main] [c.e.c.s.CoreStartupApplication.init(44)] -  Not able to initialize services, missing required certificates. 


If using only 1 or 2 DNS entries, the deployment\upgrade will be successful.

Cause

The certificate generation process fails because it is not able to perform an NSLOOKUP of PowerProtect Reporting node ip address to get the FQDN name.

While performing any NSLOOKUP on the Reporting Node, the following error will be thrown:

ppreportingengine:# nslookup 10.10.0.42

nslookup: parse of /etc/resolv.conf failed 


The failure is caused due to the content of hte /etc/resolv.conf file. Instead of having separate entries for each DNS ip address (i.e Primary ,Secondary and Tertiary), the secondary and Tertiary DNS entries were merged together and separated by a comma:

nameserver 192.168.9.100
nameserver 192.168.9.1,192.168.9.2

Resolution

Dell Technologies recommends that users upgrade to PowerProtect Data Manager versions later than 19.17.0-10.

To workaround the issue, please contact Dell Technical Support to assist.
Article Properties
Article Number: 000228160
Article Type: Solution
Last Modified: 30 أغسطس 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.