PowerProtect backup fails for deleted VM with ABV0040
Summary: The PowerProtect Data Manager appliance is used to protect the vSphere environment with the Transparent Snapshot Data Mover (TSDM) solution. The Protection Policy is configured with a Protection Rule selecting virtual machines (VM) using their tags. The virtual machine backups fail with ABV0040 indicating the virtual machine does not exist. ...
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Symptoms
The backup session details show:
ABV0040: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm' on vCenter 'my-vcenter.domain.local' because of a connectivity issue between vCenter and the ESXi host 'my-esx.my-domain.local'. The VM Direct engine cannot complete the backup of this virtual machine because a connection with the connection between the vCenter and the ESXi host. Read Less Unable to find virtual machine with MORef 'vm-1681749'. Virtual machine does not exist with MORef 'vm-1681749': ServerFaultCode: The object 'vim.VirtualMachine:vm-1681749' has already been deleted or has not been completely created
The backup session log shows:
YYYY-MM-DD HH:MM:SS INFO: [b1a05adff5c8c442;a40b08944d546ef7] Connect vCenter: Connected to session on vCenter 'my-vcenter.my-domain.com' Version '7.0.3 build-24322018, API:7.0.3.0', Uuid:6ef15986-74fb-4631-a249-99294227364b.
YYYY-MM-DD HH:MM:SS ERROR: [b1a05adff5c8c442;a40b08944d546ef7] Connect vCenter: Virtual machine does not exist with MORef 'vm-1681749': ServerFaultCode: The object 'vim.VirtualMachine:vm-1681749' has already been deleted or has not been completely created
YYYY-MM-DD HH:MM:SS ERROR: [b1a05adff5c8c442;a40b08944d546ef7] Connect vCenter: Unable to find virtual machine with MORef 'vm-1681749'.
YYYY-MM-DD HH:MM:SS INFO: [b1a05adff5c8c442;a40b08944d546ef7] Connect vCenter: Disconnected from session on vCenter 'my-vcenter.my-domain.com'.
The Asset Counts for under "Protection > Protection Policies" showed a higher count compared to the Assigned Assets Count under "Protection > Protection Rules."
Cause
The Protection Policy Asset Count is not being updated from the Protection Rule. The cause of the symptom is not known.
Resolution
Update the Protection Rule Conditions and save the changes to force an update. A condition can be added and then removed to ensure that it reflects the previous configuration.
Article Properties
Article Number: 000263921
Article Type: Solution
Last Modified: 09 يناير 2026
Version: 2
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