NetWorker : Abonnement Azure manquant dans NWUI

Summary: Un abonnement Microsoft Azure a été précédemment ajouté à NetWorker. L’abonnement Azure ne s’affiche pas dans l’interface utilisateur Web (NWUI) de NetWorker. Lors de la tentative de rajout de l’abonnement Azure, une erreur s’affiche, indiquant que l’abonnement Azure existe déjà dans NetWorker. L’abonnement est visible à partir d’une invite nsradmin sur le NetWorker Server. ...

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Symptoms

Un abonnement Azure a été précédemment ajouté au serveur NetWorker. NetWorker Web Use Interface (NWUI) n’affiche aucun abonnement Azure :

Abonnements Azure NWUI

Toute tentative d’ajout de l’abonnement Azure à NetWorker signale qu’il existe déjà :

Un abonnement Azure existe déjà

Le daemon.log du serveur NetWorker peut signaler :

66113 MM/DD/YYYY HH:mm:SS  nsrd NSR critical Failed to retrieve item _azure_AZURE_SUBSCRIPTION_NAME_client secret from lockbox /nsr/lockbox/NETWORKER_SERVER_FQDN/clb.lb

L’abonnement Azure peut être vu à partir d’un nsradmin sur le serveur NetWorker :

  1. Ouvrez une invite avec élévation de privilèges sur le NetWorker Server.
  2. Exécutez la commande suivante : nsradmin
  3. À partir de l’invite nsradmin, répertoriez les abonnements Azure : print type: NSR Azure Subscription
azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p type: NSR Azure Subscription
                        type: NSR Azure Subscription;
                        name: SUBSCRIPTION-RESOURCE-NAME;
                     comment: ;
                   tenant id: AZURE-TENANT-ID;
             subscription id: AZURE-SUBSCRIPTION-ID;
                   client id: AZURE-CLIENT-IDb;
               client secret: *******;
                    endpoint: management.azure.com;
                     command: nsrazure_discovery;
               administrator: "user=root,host=azure-nve.local",
                              "user=administrator,host=azure-nve.local",
                              "user=system,host=azure-nve.local",
                              "user=nsrnmc,host=azure-nve.local",
nsradmin> quit
Remarque : Si l’abonnement Azure n’est pas répertorié dans la base de données de ressources du serveur NetWorker (NSRDB), cet article de la base de connaissances n’est pas applicable. Cet article de la base de connaissances s’applique uniquement lorsque la ressource existe toujours dans la NSRDB, mais qu’elle n’est pas affichée dans NWUI ou NMC.

Cause

Plusieurs problèmes peuvent être à l’origine de ces symptômes.
  • Le lockbox du NetWorker Server est corrompu.
  • NetWorker n’est pas en mesure de déchiffrer le code secret client de l’abonnement Azure à partir du lockbox.
  • Le code secret du client Azure a une période d’expiration définie lors de sa création. La date d’expiration est dépassée et le code secret client utilisé dans la ressource Abonnement NetWorker Azure n’est plus valide.

Resolution

AVERTISSEMENT : Suivez cet article de la base de connaissances uniquement si des abonnements Azure existent sur NetWorker Server , mais ne sont pas visibles dans NWUI. Si les abonnements sont déjà visibles dans NWUI, n’appliquez pas cette procédure, car cela rompt la configuration et entraîne la disparition des abonnements de NWUI.

 

  1. Sur le NetWorker Server, créez un fichier appelé clear_client_secret.txt à l’endroit de votre choix.
  2. Ajoutez le contenu suivant au fichier et enregistrez-le :
. type: nsr azure subscription
update client secret: ;
y
  1. À partir d’un shell root (Linux) ou d’une invite de commande administrateur (Windows), arrêtez les services du serveur NetWorker :
  • Linux : nsr_shutdown
  • Windows. : net stop nsrd
  1. Créez une copie de la base de données de ressources du NetWorker Server (NSRDB) :
Remarque : En cas de problème, vous pouvez revenir à cette copie.
  • Linux : cp -R /nsr/res/nsrdb /nsr/res/nsrdb.beforeclientsecretreset_$(date -I)
  • Windows. : Utilisez l’Explorateur de fichiers Windows pour créer une copie du dossier de la base de données de ressources, chemin par défaut : C :\Program Files\EMC NetWorker\nsr\res\nsrdb
  1. À utiliser nsradmin pour importer le fichier clear_client_secret.txt dans la base de données nsrdb.
  • Linux : nsradmin -i clear_client_secret.txt -d /nsr/res/nsrdb
  • Windows. : nsradmin -i clear_client_secret.txt -d "C:\Program Files\EMC NetWorker\nsr\res\nsrdb"
Remarque : Si le clear_client_secret.txt ne se trouve pas dans le même répertoire que celui à partir duquel vous exécutez la commande, vous devez spécifier le chemin d’accès complet au fichier. Vous devez également spécifier le chemin d’accès complet à votre dossier nsrdb.

Exemple :

azure-nve:~ # nsradmin -i clear_client_secret.txt -d /nsr/res/nsrdb
Current query set
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(186)

Une ligne « ressource mise à jour » s’affiche pour chaque abonnement Azure configuré sur le NetWorker Server.

  1. Ouvrez un nsradmin invite à la base de données nsrdb et met à jour l’abonnement client pour chaque abonnement Azure.
  • Linux : nsradmin -d /nsr/res/nsrdb
  • Windows. : nsradmin -d "C:\Program Files\EMC NetWorker\nsr\res\nsrdb"

Si tous les abonnements Azure partagent la même clé secrète de client Azure, procédez comme suit :

nsradmin> . type: nsr azure subscription
Current query set
nsradmin> show name; client secret
nsradmin> print
               client secret: ;
                        name: Azure;
nsradmin> update cleint secret: REPLACE_WITH_CLIENT_SECRET
               cleint secret: CLIENT_SECRET;
Update? y
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(187)
*Repeat confirmation for each subscription*
nsradmin> q
S’il existe plusieurs abonnements Azure, à l’aide de différents secrets client, procédez comme suit pour chaque abonnement Azure :
nsradmin> show name
nsradmin> print type: nsr azure subscription
                        name: AZURE_SUBSCRIPTION_NAME;
nsradmin> . type: nsr azure subscription; name: AZURE_SUBSCRIPTION_NAME
Current query set
nsradmin> update client secret: REPLACE_WITH_CLIENT_SECRET
               client secret: CLIENT_SECRET;
Update? y
updated resource id 53.0.36.27.0.0.0.0.220.76.162.103.10.164.158.89(188)
Répétez cette opération pour chaque ressource d’abonnement Azure, une fois terminé, saisissez q ou quit pour quitter nsradmin.
  1. Démarrez les services du serveur NetWorker :
  • Linux : systemctl start networker ou /etc/init.d/networker start
  • Windows. : net start nsrd
  1. Surveillez la daemon.raw du serveur pour détecter toute nouvelle erreur du lockbox :
  1. Si aucune erreur du lockbox n’est signalée concernant les abonnements Azure, vérifiez que vous pouvez actualiser les abonnements à partir de NWUI après le démarrage du service.

Additional Information

Si la procédure ci-dessus ne fonctionne pas. Les abonnements Azure doivent être supprimés et recréés.

 

  1. Créez une copie de nsrdb (si ce n’est pas déjà fait). Si vous effectuez ces étapes après avoir tenté la procédure ci-dessus, une copie a été créée à l’étape de résolution 4. En outre, assurez-vous que la tâche de protection du serveur a été terminée. Collectez les détails du saveset de bootstrap : mminfo -B
  2. Collectez les détails de l’abonnement Azure à partir de l’invite nsradmin. Cette liste répertorie tous les éléments, sauf le code secret du client. Vous devez les collecter avant de passer aux étapes suivantes. L’administrateur Azure doit effectuer ces actions ; Toutefois, reportez-vous au code secret du client Azure ci-dessous pour connaître les étapes générales requises.
nsradmin
print type: nsr azure subscription
Remarque : Copiez la sortie de la commande ci-dessus dans un fichier texte. Il s’agit des conditions requises pour recréer l’abonnement Azure.
  1. Supprimer les ressources d’abonnement Azure existantes 
. type: nsr azure subscription
delete
y
Remarque : Vous êtes invité à supprimer l’abonnement Azure (s’il en existe plusieurs) jusqu’à ce qu’il n’en reste plus.
  1. Connectez-vous à NetWorker Web User Interface (NWUI) et accédez à Protection-Azure> Subscriptions.
  2. Recréez chaque abonnement Azure à l’aide du nom, du commentaire, de l’ID de client, de l’ID d’abonnement et de l’ID client collectés à l’étape 2. Le code secret client doit être fourni par le client ou son administrateur Azure

Azure Client Secret

Si le code secret du client Azure actuel n’est pas connu, vous pouvez en créer un nouveau à partir d’Azure. Seuls les comptes d’utilisateur Azure disposant des autorisations appropriées peuvent afficher ces paramètres et ressources. Cela nécessite l’administrateur Azure de l’environnement.

  1. À partir du portail Azure, accédez à (ou Rechercher) Enregistrements d’applications.
  2. Dans App Registrations, des entrées doivent exister pour chaque ID client. La valeur du nom peut différer, mais l’ID client doit correspondre à ceux utilisés dans NetWorker :

Inscriptions d’applications Azure

  1. Ouvrez le portail d’enregistrement de l’application en cliquant sur son nom d’affichage.
  2. À partir de l’écran Ressource d’enregistrement d’application, développez le menu déroulant Gérer , puis cliquez sur Certificats et secrets

Options de gestion des ressources d’application

  1. Dans la fenêtre Certificats et secrets, vous voyez les secrets précédemment créés pour la ressource Enregistrement d’application :

Certificats et secrets

Remarque : Vous ne pouvez pas afficher un secret client qui a été précédemment créé. Il n’est visible qu’immédiatement après sa création. Si l’administrateur Azure ne connaît pas le secret actuel. Vous devez en créer un nouveau. Utilisez le nouveau code secret client lors de la recréation de l’abonnement Azure dans NetWorker.

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000345333
Article Type: Solution
Last Modified: 10 نوفمبر 2025
Version:  6
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