NetWorker : Alerte de licence « Échec de la conversion de la licence Flexera en licence XML »
Summary: Une erreur de licence NetWorker s’affiche dans NetWorker Management Console. Warning NetWorker x/x/x, x :xx :xx PM registration Échec de la conversion de la licence Flexera en licence XML. Contactez l’équipe de gestion des licences DELL pour obtenir une nouvelle licence XML et mettre à jour le fichier de propriétés licspec. Consultez le Guide de licence pour plus d’informations. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Le message d’avertissement suivant s’affiche dans NetWorker Management Console (NMC) :
Warning NetWorker x/x/x, x:xx:xx PM registration Conversion of Flexera License to XML License failed. Please contact the DELL Licensing Team to obtain a new XML License and update the licspec properties file. Refer to the Licensing Guide for details.
Cause
Problème observé après la mise à niveau du serveur vers NetWorker version 19.13.x.
Suite à la mise à niveau de NetWorker Server vers la version 19.13.x, une erreur liée à la compatibilité des fichiers de licence a été signalée. Dans NetWorker 19.13 et versions ultérieures, le mécanisme d’octroi de licence a été mis à jour pour prendre uniquement en charge .xml fichiers de licence. Les fichiers de licence .lic précédemment utilisés ne sont plus reconnus ni pris en charge dans cette version. Par conséquent, toute tentative d’utilisation d’un fichier .lic après la mise à niveau entraîne des erreurs ou des échecs de licence lors de l’initialisation du service.
Suite à la mise à niveau de NetWorker Server vers la version 19.13.x, une erreur liée à la compatibilité des fichiers de licence a été signalée. Dans NetWorker 19.13 et versions ultérieures, le mécanisme d’octroi de licence a été mis à jour pour prendre uniquement en charge .xml fichiers de licence. Les fichiers de licence .lic précédemment utilisés ne sont plus reconnus ni pris en charge dans cette version. Par conséquent, toute tentative d’utilisation d’un fichier .lic après la mise à niveau entraîne des erreurs ou des échecs de licence lors de l’initialisation du service.
Resolution
Pour résoudre ce problème, assurez-vous d’obtenir et d’appliquer un fichier de licence .xml valide compatible avec NetWorker 19.13.x. Vous pouvez demander le fichier de licence mis à jour au représentant du support de licences Dell.
Une fois que vous avez obtenu le fichier de licence .xml valide auprès de Dell, suivez les étapes ci-dessous pour l’appliquer à votre serveur NetWorker :
- Selon le système d’exploitation, procédez comme suit :
- Dans toutes les versions de Linux :
- Arrêtez les services NetWorker.
- Modifiez le
licspec.propertiesFichier dans/nsr/lic, puis ajoutez les entrées suivantes :
license.technology=XML license.path=/nsr/lic/dpa.xml
- Démarrez les services NetWorker.
Remarque : Modifiez le chemin d’accès de la licence de
/nsr/lic/dpa.lic to /nsr/lic/dpa.xml.
- Dans toutes les versions de Windows :
- Arrêtez les services NetWorker.
- Modifiez le
licspec.propertiesFichier dansC:\Program Files\EMC NetWorker\nsr\lic, puis ajoutez les entrées suivantes :
license.technology=XML license.path=/nsr/lic/dpa.xml
- Démarrez les services NetWorker.
Remarque : Modifiez le chemin d’accès de la licence de
/nsr/lic/dpa.lic to /nsr/lic/dpa.xml.
- Sur le NetWorker Server, lancez la fenêtre Administration de NMC , cliquez avec le bouton droit de la souris sur le serveur, puis sélectionnez Properties dans la liste. La fenêtre Server Properties s’affiche.
- Sélectionnez l’onglet Licensing .
- Dans le champ CLP license text, cliquez sur Browse.
- Accédez à l’emplacement du fichier de licence, puis sélectionnez-le.
- Cliquez sur Validate License. Le bouton Validate license est désactivé jusqu’à ce que le contenu soit validé. Vous pouvez vérifier l’état à l’aide de la commande
nsrlic -C.
- Dans la fenêtre Server Properties, sous l’onglet Licensing, assurez-vous que les champs suivants ont les valeurs correctes, puis cliquez sur OK.
- Solution ID
- CLP SWID4
Dans la fenêtre Administration de NMC , cliquez sur Server, puis sélectionnez Registrations. Vérifiez que le volet de droite affiche une entrée pour CLP Capacity License qui indique la Authorized -No expiration date.
Pour plus d’informations, reportez-vous au Guide d’octroi de licence de Dell NetWorker . Le Guide d’octroi de licence est accessible à l’adresse suivante : Prise en charge de NetWorker | Manuels et documents
Affected Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000348333
Article Type: Solution
Last Modified: 17 مارس 2026
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.