NetWorker: Licensieringsvarningen "Konvertering av Flexera-licens till XML-licens misslyckades"

Summary: Ett NetWorker-licensieringsfel visas i NetWorker Management Console. Varning NetWorker-registrering för x/x/x, x:xx:xx PM Konvertering av Flexera-licens till XML-licens misslyckades. Kontakta DELLs licensieringsteam för att få en ny XML-licens och uppdatera filen med licspec-egenskaper. Mer information finns i licensieringsguiden. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Följande varningsmeddelande visas i NetWorker Management Console (NMC):

Warning NetWorker  x/x/x, x:xx:xx PM registration Conversion of Flexera License to XML License failed. Please contact the DELL Licensing Team to obtain a new XML License and update the licspec properties file. Refer to the Licensing Guide for details.

Cause

Problem som observerats efter serveruppgradering till NetWorker version 19.13.x.

Efter uppgraderingen av NetWorker-servern till version 19.13.x rapporterades ett fel relaterat till kompatibilitet med licensfiler. I NetWorker version 19.13 och senare har licensmekanismen uppdaterats till att endast stödja .xml licensfiler. De tidigare använda .lic-licensfilernakänns inte längre igen eller stöds inte längre i den här versionen. Det innebär att försök att använda en .lic-fil efter uppgraderingen leder till licensfel eller fel under initieringen av tjänsten.

Resolution

VARNING! Stegen i artikeln kan lösa problemet med hjälp av din befintliga licensfil. Om du inte har en giltig .lic-fil, eller om problemet kvarstår efter att du har följt den här artikeln, måste du kontakta Dells licensieringsavdelning för att få en ny .xml licensfil.
  1. Beroende på operativsystemet utför du följande steg:

För Linux-servrar:

  1. Stoppa NetWorker-tjänsterna: nsr_shutdown eller systemctl stop networker
  2. Byt namn på licensfilen från /nsr/lic/dpa.lic Att /nsr/lic/dpa.xml
  3. Redigera /nsr/lic/licspec.properties och lägg till följande poster:
license.technology=XML

license.path=/nsr/lic/dpa.xml
  1. Starta NetWorker-tjänsterna: systemctl start networker

För Windows-servrar:

Obs! Sökvägarna som visas är NetWorker-standardinstallationssökvägen. Om du har installerat NetWorker på en annan plats justerar du sökvägarna därefter. Licensfilerna finns i ..\nsr\lic i förhållande till var du installerade NetWorker.
  1. StoppaNetWorker-tjänsterna: net stop nsrd
  2. Byt namn på licensfilen från C:\Program Files\EMC NetWorker\nsr\lic\dpa.lic Att C:\Program Files\EMC NetWorker\nsr\lic\dpa.xml.
  3. Redigera C:\Program Files\EMC NetWorker\nsr\lic\licspec.properties och lägg till följande poster:
license.technology=XML

license.path="C:\Program Files\EMC NetWorker\nsr\lic\dpa.xml"
  1. Starta NetWorker-tjänsterna: net start nsrd

 

  1. Starta fönstret NMC-administration på NetWorker-servern, högerklicka på servern och välj sedan Egenskaper i listan. Fönstret Serveregenskaper visas.
    1. Välj fliken Licensiering .
    2. I textfältet CLP-licens klickar du på Browse.
    3. Gå till platsen för licensfilen och välj licensfilen.
    4. Klicka på Validera licens. Knappen Validera licens är inaktiverad tills innehållet har verifierats. Du kan kontrollera statusen med hjälp av nsrlic -C Kommandot.
  2. Kontrollera att följande fält har rätt värden på fliken Licensiering i fönstret Serveregenskaper och klicka sedan på OK.
  • Lösnings-ID
  • CLP SWID4
I fönstret NMC-administration klickar du på Server och väljer sedan Registreringar. Kontrollera att det i den högra rutan visas en post för CLP-kapacitetslicens som anger förfallodatumet Auktoriserad -Nej.


Fullständig information finns i licensieringsguiden för Dell NetWorker . Licensieringsguiden finns under: Stöd för NetWorker | Manualer och dokument 

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000348333
Article Type: Solution
Last Modified: 27 أبريل 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.