Dataskyddscentralen: UI-inloggning misslyckas med "401 Unauthorized"

Summary: Efter en DPC- eller IDPA-uppgradering kanske användarna inte kan logga in på DPC-gränssnittet (Data Protection Center). Inloggningsfelet beror på ett synkroniseringsproblem mellan IAM-tjänsten (Identity and Access Management) och Keycloak. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • DPC UI-inloggning misslyckas med ett 401 Obehörigt fel.

  • Följande fel visas i IAM-tjänstloggen (/var/log/dpc/iam/iam-service/iam-services.log):

    • WebClientRequestException: finishConnect(..) failed: Connection refused: iam-provider:<IPv6>:8443
      IAMExchangeException(errorMessage=Cannot get admin access token, httpStatus=401 UNAUTHORIZED)

Cause

Problemet orsakas av ett lösenordssynkroniseringsfel mellan IAM-tjänsten och Keycloak-identitetsprovidern.
Detta förhindrar att IAM-tjänsten hämtar nödvändig administratörsåtkomsttoken, vilket resulterar i inloggningsfel.

Resolution

Det här problemet kräver åtgärder från Dells support.
Så här löser du problemet:

  1. Försök inte att starta om tjänster eller ändra IAM-/tangentbordskonfigurationer manuellt.
  2. Öppna en tjänstebegäran hos Dells support och läs denna KB-artikel (#000375379) för att påskynda åtgärden.

Dells support utför de backend-åtgärder som krävs för att återställa synkroniseringen och lösa inloggningsproblemet.

Affected Products

Data Protection Central
Article Properties
Article Number: 000375379
Article Type: Solution
Last Modified: 05 نوفمبر 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.