PowerProtect Data Manager: TSDM-varmuuskopioinnit epäonnistuvat ja näyttöön tulee virhe InvalidProperty:vendorId

Summary: PowerProtect Data Managerin TSDM (Transparent Snapshot Data Mover) -varmuuskopiointi epäonnistuu ja näyttöön tulee virhe InvalidProperty:vendorId. Tämä ongelma johtuu VMware vCenterin ja ESXi-isännän välisestä virheellisestä määrityksestä tai vanhentuneesta rekisteröinnistä, joka estää tietosuojapalvelua (DPS) luomasta tilannevedoksia. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Instructions

Oireet

  • Varmuuskopiointityöt epäonnistuvat tilannevedoksen luonnin aikana.
  • Istuntolokeissa näkyy:
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
  • vSAN Health -lokiraportti:
DPD LRO request failed
Async LRO 'Snapshot' failed for 'vim.VirtualMachine'
  • dpd.log Merkintöjä ovat:
Missing syncId
No VendorId provided
Task failed with error: InvalidArgument: invalidProperty = "vendorId"

Lokianalyysi:

Varmuuskopiointi-istuntolokit:

  • Tilannevedostyö epäonnistuu
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
DEBUG: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: taskInfo.Error.Fault = '*types.InvalidArgument', &{RuntimeFault:{MethodFault:{FaultCause:<nil> FaultMessage:[]}} InvalidProperty:vendorId}
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: vCenter task 'task-29959637' failed.
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: Unable to create LWD snapshot.

vSAN Health -lokit:

  • Virhesanomien analysointi

Toistuva virhe:

(vmodl.fault.InvalidArgument) {
   invalidProperty = "vendorId"
}

Tämä osoittaa, että vendorId Ominaisuus puuttuu tai on virheellinen, kun tilannevedostehtävä käynnistetään. Tämä on suora vihje siitä, että järjestelmä odottaa tämän ominaisuuden olevan läsnä ja pätevä toiminnan onnistumiseksi.

error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] DPD LRO request failed, host: host-#####(hostname), api: Snapshot, pe: (dp.vpx.VirtualMachineProtectedEntity) {
-->    vmRef = 'vim.VirtualMachine:vm-####',
-->    includedDiskKeys = (int) [
-->       2000,
-->       2001
-->    ]
--> }, dpdTask: 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a', dpsVcTask: 'vim.Task:task-30014504', dpd taskinfo: (vim.TaskInfo) {
-->    key = "Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a",
-->    task = 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a',
-->    name = "dp.ProtectionService.snapshot",
-->    descriptionId = "",
-->    state = "error",
-->    cancelled = false,
-->    cancelable = false,
-->    error = (vmodl.fault.InvalidArgument) {
-->       invalidProperty = "vendorId",
-->       msg = "",
-->    },
-->    progress = 0,
-->    reason = (vim.TaskReasonSystem) {
-->    },
-->    queueTime = "2025-09-19T00:06:24.000988Z",
-->    startTime = "2025-09-19T00:06:24.001002Z",
-->    completeTime = "2025-09-19T00:06:24.001186Z",
-->    eventChainId = 0,
-->    changeTag = "0",
--> }
2025-09-19T00:06:24.018Z error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] Async LRO 'Snapshot' failed for 'vim.VirtualMachine:vm-1964341', fault: (vmodl.fault.InvalidArgument) {
-->    invalidProperty = "vendorId",
-->    msg = "",
--> }

dpd.log:

Missing syncId
No VendorId provided

Nämä sanomat vahvistavat, että Data Protection Daemon (DPD) ei voi noutaa tai määrittää vendorId, joka on välttämätön tilannevedostoiminnoissa.

2025-09-22T06:54:01.265Z Er(163) dpd[2215779]: [Originator@6876 sub=VmomiProtectionService opID=9a42e00a-e00c] Missing syncId
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=VmomiProtectionService opID=9a42e0ac-e0ad] No VendorId provided
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=Task opID=9a42e0ac-e0ad] Task 'Dp.Task.Snapshot.528967a1-7f4c-46d1-b3d1-db7a816732fb' failed with error: (vmodl.fault.InvalidArgument) {
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultCause = (vmodl.MethodFault) null,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultMessage = <unset>,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    invalidProperty = "vendorId"
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    msg = ""
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: --> }
2025-09-22T06:54:16.596Z Er(163) dpd[2215788]: [Originator@6876 sub=VmomiProtectionService opID=9a42e1fc-e1fd] Missing syncId
2025-09-22T06:54:18.724Z Er(163) dpd[2215768]: [Originator@6876 sub=VmomiProtectionService opID=9a42e23c-e23d] No VendorId provided`    
 

Syy

ESXi-isäntää ei ole rekisteröity oikein vCenterin tietosuojapalveluun (DPS). Tämän vuoksi Data Protection Daemon (DPD) ei voi noutaa tai määrittää tarvittavia tiedostoja vendorId -ominaisuus, joka johtaa tilannevedostehtävien epäonnistumiseen. Tämä johtuu yleensä seuraavista syistä:

  • Vanhentunut isännän rekisteröinti vCenterissä
  • vCenter ei käytä uusinta korjaustiedostotasoa
  • vSAN Health Service ei toimi oikein

Yhteydessä:

Arkkitehtuuri ja työnkulku:

  • PowerProtect Data Manager käyttää VM Direct Engineä → kommunikoi vCenterin DPS:n kanssa.
  • DPS etsii oikean ESXi-isännän ja käynnistää tehtävät.
  • Isännän DPD käsittelee suojausohjelmointirajapintoja ja on vuorovaikutuksessa TSDM:n kanssa.

Jos ESXi-isäntää ei ole rekisteröity oikein DPS:ään/DPD:hen, vendorId-tunnusta ei määritetä, mikä vastaa virhettä.


Resolution (tarkkuus)

Koordinoi VMware-tiimin kanssa seuraavat korjausvaiheet:

  1. Käynnistä vSAN Health Service
    uudelleen Vaihtoehtoisesti voit päivittää sisäiset tilat käynnistämällä kaikki vCenter-palvelut uudelleen.

  2. Yhdistä ESXi-isäntä
    uudelleen Irrota altistunut ESXi-isäntä vCenteristä ja liitä se uudelleen DPS:ään tai DPD:hen.

  3. Päivitä vCenter
    Varmista, että vCenter on päivitetty uusimpaan koontiversioon, jotta voidaan ratkaista tunnetut ohjelmointirajapinnan ongelmat, jotka liittyvät vendorId

Lisätietoja on seuraavissa aiheeseen liittyvissä artikkeleissa:

Affected Products

PowerProtect Data Manager

Products

Data Protection Suite Series
Article Properties
Article Number: 000381740
Article Type: How To
Last Modified: 07 يناير 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.