PowerProtect Data Manager : Les sauvegardes TSDM échouent avec l’erreur InvalidProperty :vendorId

Summary: Les sauvegardes de PowerProtect Data Manager à l’aide de Transparent Snapshot Data Mover (TSDM) échouent avec l’erreur InvalidProperty :vendorId. Ce problème provient d’une mauvaise configuration ou d’un enregistrement obsolète entre VMware vCenter et l’hôte ESXi, ce qui empêche la création de snapshots par le service de protection des données (DPS). ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Instructions

Symptômes

  • Les procédures de sauvegarde échouent lors de la création du snapshot.
  • Les journaux de session affichent les éléments suivants :
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
  • Rapport des journaux d’intégrité vSAN :
DPD LRO request failed
Async LRO 'Snapshot' failed for 'vim.VirtualMachine'
  • dpd.log Les entrées sont les suivantes :
Missing syncId
No VendorId provided
Task failed with error: InvalidArgument: invalidProperty = "vendorId"

Analyse des fichiers log :

Sauvegarder les logs de session :

  • Échec de la tâche de snapshot
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
DEBUG: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: taskInfo.Error.Fault = '*types.InvalidArgument', &{RuntimeFault:{MethodFault:{FaultCause:<nil> FaultMessage:[]}} InvalidProperty:vendorId}
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: vCenter task 'task-29959637' failed.
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: Unable to create LWD snapshot.

Journaux d’intégrité vSAN :

  • Analyse des messages d’erreur

L’erreur récurrente :

(vmodl.fault.InvalidArgument) {
   invalidProperty = "vendorId"
}

Cela indique que l’option vendorId La propriété est manquante ou non valide lorsque la tâche de snapshot est lancée. Il s’agit d’un indice direct que le système s’attend à ce que cette propriété soit présente et valide pour que l’opération réussisse.

error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] DPD LRO request failed, host: host-#####(hostname), api: Snapshot, pe: (dp.vpx.VirtualMachineProtectedEntity) {
-->    vmRef = 'vim.VirtualMachine:vm-####',
-->    includedDiskKeys = (int) [
-->       2000,
-->       2001
-->    ]
--> }, dpdTask: 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a', dpsVcTask: 'vim.Task:task-30014504', dpd taskinfo: (vim.TaskInfo) {
-->    key = "Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a",
-->    task = 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a',
-->    name = "dp.ProtectionService.snapshot",
-->    descriptionId = "",
-->    state = "error",
-->    cancelled = false,
-->    cancelable = false,
-->    error = (vmodl.fault.InvalidArgument) {
-->       invalidProperty = "vendorId",
-->       msg = "",
-->    },
-->    progress = 0,
-->    reason = (vim.TaskReasonSystem) {
-->    },
-->    queueTime = "2025-09-19T00:06:24.000988Z",
-->    startTime = "2025-09-19T00:06:24.001002Z",
-->    completeTime = "2025-09-19T00:06:24.001186Z",
-->    eventChainId = 0,
-->    changeTag = "0",
--> }
2025-09-19T00:06:24.018Z error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] Async LRO 'Snapshot' failed for 'vim.VirtualMachine:vm-1964341', fault: (vmodl.fault.InvalidArgument) {
-->    invalidProperty = "vendorId",
-->    msg = "",
--> }

dpd.log:

Missing syncId
No VendorId provided

Ces messages confirment que le processus de protection des données (DPD) ne parvient pas à récupérer ou à attribuer le vendorId, ce qui est essentiel pour les opérations de snapshot.

2025-09-22T06:54:01.265Z Er(163) dpd[2215779]: [Originator@6876 sub=VmomiProtectionService opID=9a42e00a-e00c] Missing syncId
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=VmomiProtectionService opID=9a42e0ac-e0ad] No VendorId provided
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=Task opID=9a42e0ac-e0ad] Task 'Dp.Task.Snapshot.528967a1-7f4c-46d1-b3d1-db7a816732fb' failed with error: (vmodl.fault.InvalidArgument) {
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultCause = (vmodl.MethodFault) null,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultMessage = <unset>,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    invalidProperty = "vendorId"
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    msg = ""
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: --> }
2025-09-22T06:54:16.596Z Er(163) dpd[2215788]: [Originator@6876 sub=VmomiProtectionService opID=9a42e1fc-e1fd] Missing syncId
2025-09-22T06:54:18.724Z Er(163) dpd[2215768]: [Originator@6876 sub=VmomiProtectionService opID=9a42e23c-e23d] No VendorId provided`    
 

Cause

L’hôte ESXi n’est pas correctement enregistré auprès du service de protection des données (DPS) dans vCenter. Par conséquent, le processus de protection des données (DPD) ne peut pas récupérer ou attribuer le vendorId , entraînant des échecs de tâches de snapshot. Cela se produit généralement pour les raisons suivantes :

  • Enregistrement d’hôte obsolète dans vCenter
  • vCenter n’exécute pas le dernier niveau de correctif
  • Le service d’intégrité vSAN ne fonctionne pas correctement

Contexte:

Architecture et workflow :

  • PowerProtect Data Manager utilise VM Direct Engine → communique avec DPS dans vCenter.
  • Le DPS localise l’hôte ESXi approprié et lance des tâches.
  • DPD sur l’hôte gère les API de protection et interagit avec TSDM.

Si l’hôte ESXi n’est pas correctement inscrit auprès de DPS/DPD, l’ID de fournisseur n’est pas attribué, ce qui correspond à l’échec.


Résolution

Coordonner avec l’équipe VMware les étapes de correction suivantes :

  1. Redémarrer le service
    d’intégrité vSAN Vous pouvez également redémarrer tous les services vCenter pour actualiser les états internes.

  2. Reconnecter l’hôte ESXi Déconnectez
    et reconnectez l’hôte ESXi concerné dans vCenter pour l’enregistrer à nouveau avec DPS ou DPD.

  3. Mise à niveau de vCenter
    Assurez-vous que vCenter est mis à jour vers la dernière version pour résoudre les problèmes d’API connus liés à vendorId

Consultez les articles connexes suivants pour obtenir plus de contexte :

Affected Products

PowerProtect Data Manager

Products

Data Protection Suite Series
Article Properties
Article Number: 000381740
Article Type: How To
Last Modified: 07 يناير 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.