PowerProtect Data Manager: TSDM Yedeklemeleri InvalidProperty:vendorId Hatasıyla Başarısız Oluyor

Summary: Transparent Snapshot Data Mover (TSDM) kullanılarak yapılan PowerProtect Data Manager yedeklemeleri InvalidProperty:vendorId hatasıyla başarısız oluyor. Bu sorun, VMware vCenter ile ESXi ana bilgisayarı arasında Veri Koruma Hizmeti (DPS) tarafından anlık görüntü oluşturulmasını engelleyen bir yanlış yapılandırma veya eski kayıttan kaynaklanır. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Instructions

Belirtiler

  • Anlık görüntü oluşturma sırasında yedekleme işleri başarısız olur.
  • Oturum günlüklerinde şunlar gösterilir:
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
  • vSAN Sağlık günlükleri raporu:
DPD LRO request failed
Async LRO 'Snapshot' failed for 'vim.VirtualMachine'
  • dpd.log Girişler şunları içerir:
Missing syncId
No VendorId provided
Task failed with error: InvalidArgument: invalidProperty = "vendorId"

Günlük Analizi:

Yedekleme oturumu günlükleri:

  • Anlık görüntü işinin başarısız olması
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
DEBUG: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: taskInfo.Error.Fault = '*types.InvalidArgument', &{RuntimeFault:{MethodFault:{FaultCause:<nil> FaultMessage:[]}} InvalidProperty:vendorId}
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: vCenter task 'task-29959637' failed.
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: Unable to create LWD snapshot.

vSAN Sistem Durumu günlükleri:

  • Hata Mesajı Analizi

Yinelenen hata:

(vmodl.fault.InvalidArgument) {
   invalidProperty = "vendorId"
}

Bu, şunu gösterir: vendorId Anlık görüntü görevi başlatıldığında özellik eksik veya geçersiz. Bu, sistemin işlemin başarılı olması için bu özelliğin mevcut ve geçerli olmasını beklediğine dair doğrudan bir ipucudur.

error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] DPD LRO request failed, host: host-#####(hostname), api: Snapshot, pe: (dp.vpx.VirtualMachineProtectedEntity) {
-->    vmRef = 'vim.VirtualMachine:vm-####',
-->    includedDiskKeys = (int) [
-->       2000,
-->       2001
-->    ]
--> }, dpdTask: 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a', dpsVcTask: 'vim.Task:task-30014504', dpd taskinfo: (vim.TaskInfo) {
-->    key = "Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a",
-->    task = 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a',
-->    name = "dp.ProtectionService.snapshot",
-->    descriptionId = "",
-->    state = "error",
-->    cancelled = false,
-->    cancelable = false,
-->    error = (vmodl.fault.InvalidArgument) {
-->       invalidProperty = "vendorId",
-->       msg = "",
-->    },
-->    progress = 0,
-->    reason = (vim.TaskReasonSystem) {
-->    },
-->    queueTime = "2025-09-19T00:06:24.000988Z",
-->    startTime = "2025-09-19T00:06:24.001002Z",
-->    completeTime = "2025-09-19T00:06:24.001186Z",
-->    eventChainId = 0,
-->    changeTag = "0",
--> }
2025-09-19T00:06:24.018Z error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] Async LRO 'Snapshot' failed for 'vim.VirtualMachine:vm-1964341', fault: (vmodl.fault.InvalidArgument) {
-->    invalidProperty = "vendorId",
-->    msg = "",
--> }

dpd.log:

Missing syncId
No VendorId provided

Bu mesajlar, Data Protection Daemon'ın (DPD) veri koruma daemon'ını alamayacağını veya atayamadığını vendorId, anlık görüntü işlemleri için gereklidir.

2025-09-22T06:54:01.265Z Er(163) dpd[2215779]: [Originator@6876 sub=VmomiProtectionService opID=9a42e00a-e00c] Missing syncId
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=VmomiProtectionService opID=9a42e0ac-e0ad] No VendorId provided
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=Task opID=9a42e0ac-e0ad] Task 'Dp.Task.Snapshot.528967a1-7f4c-46d1-b3d1-db7a816732fb' failed with error: (vmodl.fault.InvalidArgument) {
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultCause = (vmodl.MethodFault) null,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultMessage = <unset>,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    invalidProperty = "vendorId"
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    msg = ""
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: --> }
2025-09-22T06:54:16.596Z Er(163) dpd[2215788]: [Originator@6876 sub=VmomiProtectionService opID=9a42e1fc-e1fd] Missing syncId
2025-09-22T06:54:18.724Z Er(163) dpd[2215768]: [Originator@6876 sub=VmomiProtectionService opID=9a42e23c-e23d] No VendorId provided`    
 

Neden

ESXi ana bilgisayarı, vCenter'da Data Protection Service'e (DPS) doğru şekilde kaydedilmemiştir. Sonuç olarak, Data Protection Daemon (DPD) gerekli bilgileri alamaz veya atayamaz vendorId özelliği, anlık görüntü görevi hatalarına yol açar. Bu durumun nedeni genellikle aşağıdakilerden kaynaklanır:

  • vCenter'da eski ana bilgisayar kaydı
  • vCenter en son yama düzeyini çalıştırmıyor
  • vSAN Sağlık Hizmeti düzgün çalışmıyor

Bağlam:

Mimari ve iş akışı:

  • PowerProtect Data Manager, vCenter'da DPS ile iletişim kurmak → VM Direct Engine kullanır.
  • DPS, doğru ESXi ana bilgisayarını bulur ve görevleri başlatır.
  • Ana bilgisayardaki DPD, koruma API'lerini işler ve TSDM ile etkileşime girer.

ESXi ana bilgisayarı DPS/DPD'ye düzgün şekilde kayıtlı değilse vendorId atanmaz ve bu hata ile uyumludur.


Çözüm

Aşağıdaki düzeltme adımlarını gerçekleştirmek için VMware ekibiyle koordinasyon sağlayın:

  1. vSAN Sistem Durumu Hizmetini
    Yeniden Başlatın Alternatif olarak, dahili durumları yenilemek için tüm vCenter hizmetlerini yeniden başlatın.

  2. ESXi Ana Bilgisayarını Yeniden Bağlayın
    : DPS veya DPD'ye yeniden kaydetmek için vCenter'da etkilenen ESXi ana bilgisayarının bağlantısını kesin ve yeniden bağlayın.

  3. vCenter'ı yükseltin: Aşağıdakilerle ilgili bilinen API sorunlarını çözmek için vCenter'ın
    en son sürüme güncellendiğinden emin olun vendorId

Ek bağlam için aşağıdaki ilgili makalelere bakın:

Affected Products

PowerProtect Data Manager

Products

Data Protection Suite Series
Article Properties
Article Number: 000381740
Article Type: How To
Last Modified: 07 يناير 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.