NetWorker: NMC GST service shuts down after starting "no OPENSSL_Applink"

Summary: An issue has been observed following an upgrade from NMC version 19.12 to 19.13, where the GST service shuts down shortly after starting.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Management Console (NMC) GST service shuts down shortly after starting. The C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw file reports the following error:

OPENSSL_Uplink(00007FFEF78455F8,08): no OPENSSL_Applink

NetWorker: How to use nsr_render_log to render .raw log files

Cause

This error is linked to OpenSSL runtime conflicts, particularly when residual files from a previous NMC version (19.12) interfere with the newly installed 19.13 version. These legacy files can cause instability in the GST service.

Resolution

Install NMC using a fresh Management folder. This avoids conflicts with legacy files and ensures that the GST service remains stable post installation. 

 

WARNING: Using a fresh Management folder means that the NetWorker Management Console Database (nmcdb) is re-created. If you use "NMC Reports," reporting data prior to the nmcdb recreation is lost. If you have integrated AD/LDAP with NetWorker, the "NMC Roles" permissions are lost.

 

The NetWorker Management Console Database (nmcdb) can be recovered using the recoverpsm command: NetWorker - How to Recover the NetWorker Management Console database

 

In scenarios where the NMCDB is not recovered but you have integrated external authentication, reenter the AD/LDAP user or group DN in the NMC External Roles fields. You can get the "External Roles" previously used by logging in to the NMC as the default Administrator account. Connect to the NetWorker server, go to Server->User Groups, open the Application Administrators group and copy the External Roles to the NMC "Console Application Administrators" role. The same process can be used for the Console Security Administrators and Console Users roles. See: NMC: AD/LDAP login fails "You do not have privileges to use NetWorker Management Console"

Additional Information

Affected Products

NetWorker
Article Properties
Article Number: 000382086
Article Type: Solution
Last Modified: 09 يناير 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.