PowerScale: I comandi Sudo di AD smettono di funzionare dopo l'aggiornamento

Summary: Dopo l'upgrade di PowerScale OneFS, i comandi sudo richiedono una password per tre volte e poi non riescono a eseguire il comando.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'utente Active Directory (in questo caso il nome utente AD è "PowerScale") con il ruolo "System Admin" consente comunque l'immissione SSH. Il comando ha esito negativo come indicato di seguito:

cluster-1# ssh DOMAIN\\PowerScale@cluster-1
(DOMAIN\PowerScale@cluster-1) Password: 
PowerScale OneFS 9.12.0.1
Could not chdir to home directory /ifs/home/DOMAIN/PowerScale: No such file or directory
cluster-1% sudo -s

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

For security reasons, the password you type will not be visible.

Password: 
Sorry, try again.
Password: 
Sorry, try again.
Password: 
sudo: 3 incorrect password attempts
cluster0-1% 

Errori in /var/log/auth.log sono simili a:

2026-01-09T14:08:46.964341-05:00 <4.6> isi-9510-1(id1) sshd[9292]: Accepted keyboard-interactive/pam for DOMAIN\PowerScale from 10.20.48.1 port 31599 ssh2
2026-01-09T14:09:02.165862-05:00 <4.1> isi-9510-1(id1) sudo[9315]: DOMAIN\PowerScale : 3 incorrect password attempts ; TTY=pts/1 ; PWD=/ ; USER=root ; COMMAND=/bin/zs

Cause

Un aggiornamento a sudo ha causato l'errore dei nomi utente di Active Directory in lettere maiuscole. Si noti che questo vale solo per gli ambienti in cui agli utenti di Active Directory viene richiesta una password; i comandi sudo senza password non dovrebbero essere interessati. I prompt protetti da password contengono voci in 'isi_visudo' Così:

DOMAIN\\powerscale ALL=(ALL) PASSWD: ALL

Resolution

PowerScale Engineering ha identificato questo problema e la correzione è disponibile in OneFS 9.13.0.2+. Gli utenti possono modificare il nome utente in Active Directory in modo che sia tutto in lettere minuscole:

Schermata delle proprietà di PowerScale

Se l'utente continua a non lavorare, avviare una raccolta registri e contattare il supporto PowerScale.

Article Properties
Article Number: 000413077
Article Type: Solution
Last Modified: 23 يونيو 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.