PowerFlex: SDC gibt I/O-Fehler zurück, ohne dass ein erneuter Aufbau ausgelöst wurde

Summary: SDC gibt I/O-Fehler an den Client zurück, wenn einige Netzwerkschnittstellen verfügbar sind, andere Schnittstellen jedoch nicht.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hinweis: In diesem Artikel wird ein bestimmtes netzwerkbezogenes Problem behandelt, das zu den unten beschriebenen Symptomen führen kann. Es ist nicht beabsichtigt, eine erschöpfende Anleitung für Netzwerkdiagnosen oder -troubleshooting bereitzustellen. Bevor Sie Änderungen am Betriebssystem oder an der Netzwerkkonfiguration vornehmen, wenden Sie sich an Ihren Systemadministrator, um sicherzustellen, dass Aktualisierungen oder Änderungen mit den Richtlinien und der Umgebung Ihres Unternehmens übereinstimmen.

 In bestimmten Netzwerktopologien sind eine oder mehrere, aber nicht alle Netzwerkschnittstellen auf einem SDC nicht verfügbar, was dazu führt, dass der SDC nicht mit einem oder mehreren SDS kommuniziert, was zu I/O-Fehlern führt.

  • Für einige oder alle Ausführungen von zurückgegebene Fehler von ping(1), vom SDC an jeden SDS
  • I/O-Fehler werden vom SDC an die Clientanwendung zurückgegeben.
  • Der SDC verliert die Verbindung zu einigen oder allen SDSs.
  • Es werden keine getrennten SDS/SDS- oder MDM/SDS-Verbindungen gemeldet.
  • Es wird keine Neuerstellung ausgelöst.

 

Auswirkungen

Anwendungen, die auf dem SDC ausgeführt werden, können nicht auf die im PowerFlex-System gespeicherten Daten zugreifen.

Cause

Der MDM wechselt die Rolle des Eigentümers der Datenkopie (primär/sekundär) nicht basierend auf dem SDC-Zugriff, was zur Wiederholung des folgenden Zyklus führt:

- Anfragen, die vom SDC an den Eigentümer der primären Datenkopie gesendet werden, schlagen fehl, da über die auf dem SDC verfügbaren Schnittstellen nicht darauf zugegriffen werden kann.

- Der SDC kontaktiert den MDM, um Aktualisierungen der primären Datenkopie und ihres Eigentümers zu erhalten.

- Der MDM hat keinen Grund, die Datenrollen zu aktualisieren, da der MDM selbst und alle anderen SDSs normal mit dem aktuellen Eigentümer der primären Datenkopie kommunizieren können.

- Der MDM antwortet dem SDC mit dem Eigentümer der primären Datenkopie, bei dem es sich um denselben SDS handelt, an den der SDC zuvor die Anfrage gesendet hat.

Dieses Verhalten entspricht dem beabsichtigten Systemdesign.

Resolution

Achtung: Wenden Sie sich an den Netzwerkadministrator des Systems, bevor Sie Änderungen vornehmen.

Falls die Ursache eine fehlende Netzwerkroutingkonfiguration auf Betriebssystemebene ist, ändern Sie die Routingkonfiguration oder die Netzwerktopologie, um einen Pfad von jeder SDC-Schnittstelle zu mindestens einer Netzwerkschnittstelle auf jedem SDS verfügbar zu haben.

Die vom Betriebssystem bereitgestellte Lösung zum Hinzufügen persistenter Routen für verschiedene Plattformen folgt. Die genaue Verwendung und Syntax finden Sie in der offiziellen Dokumentation.

Ein System verfügt möglicherweise über eine nicht standardmäßige Lösung für das Management der Routingtabelle der Hosts. In diesem Fall sollte die verfügbare Lösung über die unten beschriebene Methode verwendet werden.

Netzwerkadressen und Gateways sollten vom Netzwerkadministrator des Systems bereitgestellt werden.

 

Für ESXi 5.5/6:

Hinzufügen der entsprechenden esxcli network ip route ipv4 add Anweisungen an /etc/rc.local.

 

Für RHEL6/7:

Nehmen Sie nach Bedarf eine der folgenden Änderungen vor:

- Fügen Sie die entsprechenden ADDRESSNETMASK und GATEWAY Konfigurationsparameter und ihre Werte an die entsprechenden Schnittstellen /etc/sysconfig/network-scripts/route-Schnittstelle.

Oder

- Fügen Sie die entsprechenden any net Anweisungen an /etc/sysconfig/static-routes.

Erfordert, dass die net-tools RPM installiert sein

 

Unter Windows:      

Führen Sie die entsprechenden route -p add Befehl aus der Eingabeaufforderung.

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000433201
Article Type: Solution
Last Modified: 27 فبراير 2026
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.