NetWorker: Authentication Fails After NRE Upgrade on Linux Server

Summary: After the NetWorker Runtime Environments (NRE) upgrade on a Linux NetWorker server, NetWorker Management Console (NMC) authentication fails. The system reports errors indicating that user credentials cannot be validated. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • NetWorker Management Console (NMC) login fails with an error indicating that user credentials cannot be validated.
  • NMC displays messages such as:
“An error occurred while validating user credentials. Verify that the Dell/EMC Authentication Service is running.”
“Failed connecting to [server] (0x80004005). Couldn't connect to server.”
“Please check the server or user credentials.”
  • Execution of any authc_mgmt command fails with a connection error.
  • The following error is returned when running authentication commands:
org.springframework.web.client.ResourceAccessException: 
I/O error on POST request for "https://<NetWorker_server>:9090/auth-server/api/v1/sec/authenticate":
Connection refused
  • Only the nsrexecd and nsrlogd processes are running on the NetWorker server.

Cause

An incomplete postupgrade NRE configuration caused this issue. After the NRE upgrade, the required configuration scripts were not successfully applied, resulting in authentication services not being properly initialized. 

Resolution

Once the NRE upgrade is complete, the required postupgrade configuration scripts must be ran to properly initialize the NetWorker authentication service.

Perform the following steps from an elevated prompt on the NetWorker server.

  1. Run the NRE configuration script:
/opt/nre/nreconfig.sh
  1. Run the Authentication Service configuration script:
/opt/nsr/authc-server/scripts/authc_configure.sh
  1. Start the NetWorker service. Verify that the NetWorker processes start successfully.
systemctl start networker 
systemctl status networker
  1. Confirm that NMC login functions as expected.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Management Console
Article Properties
Article Number: 000443262
Article Type: Solution
Last Modified: 23 مارس 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.