PowerFlex:NTP 同步故障診斷和驗證

Summary: 伺服器上不正確的系統時間可能會導致關鍵問題,例如證書驗證失敗、身份驗證錯誤和升級失敗。

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Symptoms

  • 系統時間不正確或漂移
  • 憑證或 TLS 驗證失敗
  • 報告不一致時間的叢集節點
  • 與時間不符相關的升級或部署失敗

Cause

NTP (透過 chronyd 服務) 未執行、設定錯誤,或因為時間漂移過多或連線問題而無法同步。

Resolution

執行下列命令,確認時鐘已與其他系統同步,且 NTP 服務處於作用中狀態。

timedatectl status

 

確保 chrony 服務正在執行中:

systemctl status chronyd

 

檢查同步健全狀況和來源伺服器,這會顯示偏移和同步狀態,以及可連線的 NTP 伺服器及其狀態:

chronyc tracking

chronyc sources -v

 

如果時間相差幾分鐘,請重新開始編年史

systemctl restart chronyd

 

如果系統未正常同步,請強制進行時間校正

chronyc makestep

 

如果系統時間明顯不同步

  • NTP 可能不會自動調整它。手動設定接近正確值的時間:
sudo timedatectl set-time "YYYY-MM-DD HH:MM:SS"

 

範例:

sudo timedatectl set-time "2026-06-19 10:30:00"

 

修正後,時效將恢復正常同步。

 

執行步驟後,請確認系統時鐘已同步,且 NTP 來源處於作用中狀態:

timedatectl status

chronyc tracking

Additional Information

成功的 chronyc 追蹤狀態
已設定的 NTP 伺服器應列在參考 ID 下,「階層」應為大於 0 的值,且系統時間應報告遠小於 1 秒的時差: 

node1:~ # chronyc tracking
Reference ID : 64400012 (0.pool.ntp.org)
Stratum : 4
Ref time (UTC) : Mon Mar 07 17:15:39 2022
System time : 0.000001647 seconds slow of NTP time
Last offset : -0.000006101 seconds
RMS offset : 0.000020258 seconds
Frequency : 33.247 ppm slow
Residual freq : -0.000 ppm
Skew : 0.016 ppm
Root delay : 0.040418178 seconds
Root dispersion : 0.033837218 seconds
Update interval : 1024.6 seconds
Leap status : Normal

 

編年史追蹤狀態失敗

層 0 表示未同步,閏狀態顯示未同步: 

node1:~ # chronyc tracking
Reference ID : 00000000 ()
Stratum : 0
Ref time (UTC) : Thu Jan 01 00:00:00 1970
System time : 0.000000000 seconds fast of NTP time
Last offset : +0.000000000 seconds
RMS offset : 0.000000000 seconds
Frequency : 0.000 ppm slow
Residual freq : +0.000 ppm
Skew : 0.000 ppm
Root delay : 1.000000000 seconds
Root dispersion : 1.000000000 seconds
Update interval : 0.0 seconds
Leap status : Not synchronized

Affected Products

PowerFlex rack, ScaleIO, PowerFlex Software
Article Properties
Article Number: 000481224
Article Type: Solution
Last Modified: 09 يوليو 2026
Version:  3
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