DPA: Error 'Failed to connect to database' when discovering RMAN

Summary: The wizard reports 'Failed to connect to database' for Oracle Recovery Manager (RMAN); logs show sodbcOpen and OCIEnvCreate errors caused by a missing or wrong C runtime for Instant Client. ...

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Symptoms

The following error is returned in the DPA Discovery Wizard during the Start Test when attempting to discover Oracle RMAN:

Failed to connect to database


Within the dpaagent.log the following error is visible.

ERR      5644.1852     20200327:173521   sodbc.oracle.sodbc - sodbcOpen(): Failed to connect to database server. server=server_name, dbname=servicename, user=userxyz, port=2112. Error was: OCIEnvCreate() failed: -1 (-1)


DPA Agent used for collecting from Oracle is on Windows system and Oracle Instant Client has been installed

Cause

Prerequisite application missing

Resolution

Installed the required version of Microsoft Visual Studio Redistributable for the version of Oracle Instant Client which is being used. Note that some versions of the Oracle Instant Client do not require any Microsoft Visual Studio Redistributable such as 11.1.

 

Affected Products

Data Protection Advisor

Products

Data Protection Advisor
Article Properties
Article Number: 000173198
Article Type: Solution
Last Modified: 23 ذو الحجة 1447
Version:  5
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