CloudLink: Cloudlink Agent reagiert aufgrund eines Speicherlecks nicht mehr.

Summary: CloudLink Agent stürzt aufgrund eines Speicherlecks in 7.1.1 und 7.1.2 ab. KMIP-Clients sind nicht betroffen.

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Symptoms

Der Agent trennt die Verbindung zu CLC aufgrund eines Speicherlecks. Während dieses Vorgangs können Administratorvorgänge wie das Hinzufügen neuer Festplatten, das Entfernen von Laufwerken und der Austausch von Schlüsseln nicht durchgeführt werden, da der Agent ausgefallen ist. I/O-Vorgänge werden nicht beeinträchtigt, da die Festplatten bereits über die Schlüssel verfügen.

BS-Protokolle:
Linux:
Nach dem Absturz des svmd-Service unter Linux wird ein Eintrag in /var/log auf RHEL oder CentOS angezeigt, der einen Speicherfehler anzeigt.image.png
Windows:
Im Falle von Windows wird jeder Absturz in den Windows Ereignisanzeigeprotokollen protokolliert. Da der Service unter Windows möglicherweise automatisch mit den Standard-Wiederherstellungseinstellungen gestartet wird, versucht der Agent, die Verbindung zum CloudLink-Server wiederherzustellen.
 
Auf der Cloudlink Center-Webbenutzeroberfläche zeigt der Agent nach einem Serviceabsturz getrennt an:
image.png

Multisession-Protokolle zeigen an, dass die Agent-Sitzung nach einem Serviceabsturz geschlossen wird:
image.png

Cause

CloudLink hat die auf dem Agent verwendete Drittanbieter-TLS-Bibliothek auf die neueste Version aktualisiert, um die Sicherheitscompliance zu gewährleisten. Die neuere Version der Bibliothek hat den Nachrichtenaustauschfluss geändert, was dazu führt, dass Arbeitsspeicher im Agent-Code in einer Schleife zugewiesen wird.

Resolution

Lösung:
Ein Neustart des CloudLink-Agent-Service ist erforderlich, um den Service erneut zu starten.
  • Unter Linux: Der Agent-Service kann nach dem Absturz manuell neu gestartet werden. Es gibt keinen Datenverlust, da die verschlüsselte Festplatte auch verschlüsselt bleibt. Befehl zum Neustarten des Agent-Service ist service svmd restart.
  • Unter Windows: Nach dem Absturz startet Windows den Service automatisch neu, wenn die Servicewiederherstellungseinstellungen so eingestellt sind, dass der Service neu gestartet wird (Standardeinstellung). Es gibt keinen Datenverlust, da die verschlüsselte Festplatte auch verschlüsselt bleibt.

Dauerhafte Lösung:
Dieses Problem wurde in CloudLink 7.1.3 behoben.

Additional Information

Linux-Betriebssystem: Beispiel:
In einem System mit Arbeitsspeicher von 2 GB stürzt der Agent-Service nach fünf Tagen ab, wenn der Speicherverbrauch um fast 1,6 GBs mit einem durchschnittlichen Verlust von 300 MB pro Tag wächst.

Windows-Betriebssystem: Beispiel:
In einem System mit einem Arbeitsspeicher von 4 GB wächst der Arbeitsspeicherverbrauch des Agent-Service und erreicht eine Größe von etwa 1,9 GB. Es wird erwartet, dass er abstürzt, wenn er rund 3 GB mit einem durchschnittlichen Verlust von 400 MB pro Tag erreicht.

Affected Products

CloudLink SecureVM, CloudLink
Article Properties
Article Number: 000197219
Article Type: Solution
Last Modified: 26 ذو القعدة 1447
Version:  4
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