Avamar: 체크포인트가 실패했습니다. 결과는 "MSG_ERR_BADTIMESYNC"입니다.

Summary: 체크포인트가 실패했습니다. 결과는 "MSG_ERR_BADTIMESYNC"입니다.

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Symptoms

체크포인트가 실패했습니다. 결과는 "MSG_ERR_BADTIMESYNC"입니다.



Avmaint CPSatas에 다음 오류가 표시됩니다.
 
Every 2.0s: avmaint cpstatus  20:16:23 2022

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cpstatus
  generation-time="1663935384"
  tag="cp.20220923121551"
  status="error"
  stripes-completed="0"
  stripes-total="0"
  start-time="1663935351"
  end-time="1663935351"
  result="MSG_ERR_BADTIMESYNC"
  refcount="1"/>

mapall --parallel 'date'는 동기화되지 않은 노드를 표시합니다.
 
admin@utility:~/>: mapall --parallel 'date'
Using /usr/local/avamar/var/probe.xml
(0.0) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.2 'date'
(0.1) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.3 'date'
(0.2) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.4 'date'
(0.3) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.5 'date'
(0.4) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.6 'date'
(0.7) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.9 'date'
(0.6) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.8 'date'
(0.5) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.7 'date'
Fri Sep 23 13:05:21 UTC 2022
Fri Sep 23 13:05:21 UTC 2022
Fri Sep 23 13:07:17 UTC 2022 <---- out of sync node
Fri Sep 23 13:05:20 UTC 2022
Fri Sep 23 13:05:22 UTC 2022
Fri Sep 23 13:05:20 UTC 2022
Fri Sep 23 13:05:22 UTC 2022
Fri Sep 23 13:05:21 UTC 2022

ntpq -pn을 사용하여 ntp를 확인하면 의심되는 노드에서 연결이 거부된 것으로 표시됩니다.
영향을 받는 노드만 표시하도록 편집된 출력:
 
admin@utility:~/>: mapall --noerror '/usr/sbin/ntpq -pn'
Using /usr/local/avamar/var/probe.xml

(0.3) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.5 '/usr/sbin/ntpq -pn'
/usr/sbin/ntpq: read: Connection refused

영향을 받는 노드에서 직접 상태를 확인하면 ntpd가 Active임을 알 수 있습니다. activating (auto-restart) (결과: 리소스):
 
root@node03:~/>: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
  Drop-In: /run/systemd/generator/ntpd.service.d
           └─50-insserv.conf-$time.conf
   Active: activating (auto-restart) (Result: resources) since Fri 2022-09-23 13:22:35 UTC; 1min 58s ago

그러나 상태는 Active: active(running):
 
root@node03:~/#: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
  Drop-In: /run/systemd/generator/ntpd.service.d
           └─50-insserv.conf-$time.conf
   Active: active (running) since Fri 2022-09-23 14:04:37 UTC; 26s ago

ntpd 시작 시도 실패:
 
root@node03:~/#: systemctl start ntpd.service
Job for ntpd.service failed because a configured resource limit was exceeded. See "systemctl status ntpd.service" and "journalctl -xe" for details.

journalctl -xe를 검토하는 동안 'No space left on the device' 메시지가 표시됩니다.

df는 /var가 100%임을 보여줍니다.
 
admin@node03:~/#: df -kh
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs         16G  8.0K   16G   1% /dev
tmpfs            16G     0   16G   0% /dev/shm
tmpfs            16G   50M   16G   1% /run
tmpfs            16G     0   16G   0% /sys/fs/cgroup
/dev/sda5       9.8G  2.4G  7.0G  26% /
/dev/sdg1       183G  8.3G  165G   5% /ssd01
/dev/sda1       979M   50M  878M   6% /boot
/dev/sdd1       1.9T  236G  1.6T  13% /data04
/dev/sdc1       1.9T  240G  1.6T  13% /data03
/dev/sde1       1.9T  236G  1.6T  13% /data05
/dev/sdf1       1.9T  238G  1.6T  13% /data06
/dev/sdb1       1.9T  238G  1.6T  13% /data02
/dev/sda7       2.0G  2.0G     0 100% /var <-------
/dev/sda3       1.8T  267G  1.6T  15% /data01


Cause

ntpd (은)는 클럭 주파수 오차의 최신 추정치를 포함하는 /var/lib/ntp/drift/ntp.drift 에 의존합니다. /var이 100%이면 ntpd가 ntp.drift 파일을 업데이트하거나 만들 수 없으며 ntp가 제대로 작동하지 않습니다.
 

Resolution

영향을 받는 노드에서 /var에 대한 100% 사용을 조사하고 해결합니다. 수정되면 ntpd를 다시 시작합니다.
 
root@node03:~/#: systemctl restart ntpd
 
참고: 재시작에 성공해도 출력이 생성되지 않습니다.

ntpd의 상태를 확인합니다.
 
root@node03:~/#: systemctl status ntpd

다음과 유사한 결과가 관찰되어야 합니다.
 
root@node03:~/#: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2022-09-27 21:21:42 UTC; 37s ago
     Docs: man:ntpd(1)
  Process: 29442 ExecStart=/usr/sbin/start-ntpd start (code=exited, status=0/SUCCESS)
 Main PID: 29463 (ntpd)
    Tasks: 2
   CGroup: /system.slice/ntpd.service
           ├─29463 /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -c /etc/ntp.conf
           └─29464 ntpd: asynchronous dns resolver

Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 3 bond0 10.241.169.52:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 4 bond1 192.168.255.22:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 5 lo [::1]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 6 bond0 [fe80::260:16ff:feaa:2a10%11]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 7 bond1 [fe80::260:16ff:fea9:b182%12]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listening on routing socket on fd #24 for interface updates
Sep 27 21:21:42 node03 start-ntpd[29442]: Starting network time protocol daemon (NTPD)
Sep 27 21:21:42 node03 systemd[1]: Started NTP Server Daemon.

ntpq를 사용하여 ntp를 확인합니다.
 
root@node03:~/#: /usr/sbin/ntpq -pn

다음과 유사한 결과가 관찰되어야 합니다.
 
root@node03:~/#: /usr/sbin/ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.241.216.209  10.233.131.242   2 u  966 1024  377    0.558    1.559   0.600
+192.168.255.21  10.241.216.209   3 u  401 1024  377    0.152    0.521   0.420

유틸리티 노드에서 수동 체크포인트를 실행하여 해결 방법을 테스트합니다.

Affected Products

Avamar, Avamar Data Store, Avamar Data Store Gen3, Avamar Data Store Gen4, Avamar Data Store Gen4S, Avamar Data Store Gen4T, Avamar Data Store Gen5A, Avamar Server, Avamar Virtual Edition
Article Properties
Article Number: 000203791
Article Type: Solution
Last Modified: 18 ذو القعدة 1447
Version:  4
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