Dell Automation: NativeEdge Virtual Machine memory oversubscription

Summary: This article describes a deployment scenario that has been observed to cause memory oversubscription on a NativeEdge Virtual Machine (VM). Memory oversubscription may result in loss of access to the affected VMs. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During a multi-VM deployment on a single endpoint of NativeEdge an oversubscription of resources may occur.

 

In the example below, a PowerEdge R760 with 128 GB of memory was used to deploy three VMs whose combined memory allocation totalled 144 GB.

Within the Automation Platform UI, all three VMs are reported as Running.

Automation Platform UI VM list

 

Automation Platform Alerts will contain warnings for VM memory resources being exceeded.

Warning Alert with explanation

 

Attempting to open a VM console to one of the affected VMs results in the message:
‘failed to connect to server’

NativeEdge VM Console error

 

 

Cause

When deploying NativeEdge VMs in Dell Automation Platform, the system validates the resources consumed by an endpoint, including, but not limited to, memory usage. This validation is intentionally designed to allow multiple VMs to be deployed, provided that resource constraints are respected at the moment each VM is powered on.

 

 

Resolution

To recover from this condition, uninstall any VMs or deployments that cause the ECE endpoint to exceed its available resource capacity. A future version of Automation Platform will include enhanced verification to prevent these rare VM oversubscription scenarios from occurring.
 

Affected Products

Dell Automation Platform, NativeEdge Solutions, Dell Automation Platform Components, NativeEdge
Article Properties
Article Number: 000435738
Article Type: Solution
Last Modified: 27 رمضان 1447
Version:  1
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