NetWorker: NMC login fails with "There is a problem contacting the server, server_hostname"
Summary: When trying to log in to the NetWorker Management Console (NMC) server an error message stating "There is a problem contacting the server, server_hostname. Please verify that the server is running" appears. ...
Symptoms
After attempting to log in to the NetWorker Management Console (NMC), the following error message appears:
There is a problem contacting the server, server_hostname. Please verify that the server is running.
Cause
The NMC server's firewall does not allow incoming connections to TCP ports 9000 and or 9001.
Port 9000 is used by the NMC HTTP process when connecting from NMC client to NMC server.
Port 9001 is used for RPC calls from the Java console to the NMC server.
Resolution
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On the NMC server, ensure that the NMC process is running and ports 9000 and 9001 are listening:
Linux:
systemctl status gst netstat -apno | grep "9000\|9001"
Windows:
tasklist | findstr gst netstat -aof | findstr 9000 netstat -aof | findstr 9001
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Check if the operating system firewall is enabled.
Linux:
firewall-cmd --stat
Windows:
netsh advfirewall show allprofiles state
Or, search "Check firewall status"
NOTE: If the operating system firewall is already disabled, check with the network/security team to see if any network firewall exists between the NMC client and NMC server systems. -
If the firewall is enabled, temporarily disable it and confirm that you can connect to ports 9000 and 9001 from the NMC client:
Linux:
curl -v NMC_servername:port
Windows (PowerShell):
Test-NetConnection -ComputerName NMC_servername -port PORT
NOTE: If the system being used to access the NMC has NetWorker installed, you can also use the nsrports command to verify resolution and port connectivity:nsrports -t NMC_servername -p port
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If the operating system firewall must be enabled, configure the firewall rules to accept ports 9000 and 9001. These ports are detailed in the NetWorker Security Configuration Guide, available through: https://www.dell.com/support/home/product-support/product/networker/docs
NOTE: Refer to operating system vendor documentation for configuring operating system firewall rules as this can vary between distributions. If assistance is required configuring firewall rules, engage the System Administrator and local network or security teams.