NetWorker Virtual Edition: Upgrade fails "Reconfiguring NetWorker Management UI Settings (45 of 57)"

Summary: NetWorker virtual edition (NVE) upgrade fails due to port 9095 being already in use by the networker client.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A NetWorker Virtual Edition (NVE) upgrade is performed. The upgrade fails, reporting a failure when reconfiguring the NetWorker Management UI (NWUI).

The following is logged in the NVE's /data01/avamar/repo/temp/*/tmp/workflow.log:

YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 ERROR: "/opt/nwui/scripts/nwui_configure.sh -silent /space/avamar/repo/temp/NveUpgrade-19.11.0-38.avp_1737117653068/tmp/nmc_ui_config.txt", exit status=1 (error)
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: post: "/opt/nwui/scripts/nwui_configure.sh -silent /space/avamar/repo/temp/NveUpgrade-19.11.0-38.avp_1737117653068/tmp/nmc_ui_config.txt", exit status=1 (error)
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: >>> [make_temp_script] 222 very_current_user=root, as_user=, ssh command is: (rpm -q dpnserver --last | head -1) >/usr/local/avamar/var/run_command-sysout.7581.47357278886560 2>&1
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: >>> [make_temp_script] 222 very_current_user=root, as_user=admin, ssh command is: (/usr/local/avamar/bin/avhostname -f) >/usr/local/avamar/var/run_command-sysout.7581.47357278886560 2>/usr/local/avamar/var/run_command-syserr.7581.47357278886560
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: - - - - - - - BEGIN(output) - - - - - - -
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: nve.networker.lan
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: - - - - - - - END
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: "/usr/local/avamar/bin/avhostname -f", exit status=0 (success)
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: Report home message: 2025-01-17 08:05:32 -0500|nve.networker.lan|unknown|NveUpgrade|19.11.0.38|/space/avamar/repo/temp/NveUpgrade-19.11.0-38.avp_1737117653068/tmp|ReconfigureNetworkerUi|Reconfiguring NetWorker Management UI Settings (45 of 57)|ERROR: ReconfigureNetworkerUi::do   - operation failed
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 ERROR:  - operation failed
YYYY-MM-DD HH:MM:SS (TIMEZONE) 47357278886560 INFO: post:  - operation failed

NetWorker Virtual Edition: Upgrade or Install Failure Log Locations and Collection

NOTE: Depending on the NetWorker version, the (# of #) or percentage at which the upgrade fails can differ. The issue is specific to when an error is observed during configuration of the NWUI settings.

Cause

Another process is using the internal NWUI port (9095). Attempts to run the NWUI configuration script used by the NVE upgrade process returns an error stating port 9095 is in use:

# /opt/nwui/scripts/nwui_configure.sh -silent /space/avamar/repo/temp/*/tmp/nmc_ui_config.txt
WARNING: Port 9095 is already in use.
In this instance, the NetWorker client software was using port 9095:
# netstat -apno | grep 9095
tcp        0      0 :::9095                   :::*                    LISTEN      31557/nsrexecd      off (0.00/0/0)
This is because port 9095 falls within the default NetWorker port range (7937-9936). The ports are dynamically assigned, the likelihood of this event is rare.​​​​​

Resolution

  1. Open an SSH connection to the NVE and log in as admin.
  2. Switch to root:
sudo su -
  1. Validate which process is using port 9095:
netstat -apno | grep 9095
NOTE: The output reports the "Process ID/Application name."
  1. If the process is a NetWorker process (for example nsrexecd), stop NetWorker services:
nsr_shutdown
systemctl stop nwui
systemctl stop gst
NOTE: It is unlikely that another application (outside of NetWorker) is using this port; however, if you find an unrelated application using port 9095, stop it using the Linux kill command. Installing additional tools or software which are not included on the NVE by default, is not supported.
  1. Validate that no process is listening on port 9095. Repeat step 3.
  2. Once port 9095 is no longer listening, return to the NVE installation user interface and click Retry Current Task. You must log back in if the web-page timed out.
  3. Monitor the upgrade until it completes. The upgrade appears as "Completed" in the History tab.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000273642
Article Type: Solution
Last Modified: 30 ديسمبر 2025
Version:  3
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