Gå til hovedindhold
  • Afgiv ordrer hurtigt og nemt
  • Se ordrer og spor status for din forsendelse
  • Opret og få adgang til en liste med dine produkter
  • Administrer dine Dell EMC-websteder, -produkter og -kontaktpersoner på produktniveau ved hjælp af Company Administration (Virksomhedsadministration).

ECS: Fejlfinding af ECS-ydeevneproblemer

Oversigt: Fejlfinding af ECS-ydeevneproblemer.

Denne artikel er muligvis automatisk blevet oversat. Hvis du gerne vil give feedback om dens kvalitet, så giv os besked ved hjælp af formularen nederst på denne side.

Artikelindhold


Symptomer

Sådan foretager du fejlfinding af ECS-ydeevneproblemer.
 

Problemer med ydeevnen:

  • En eller flere typer handlinger er langsomme. Dette er det mest almindelige problem, da problemet konstateres fra slutprogrammer.
  • En eller flere noder er langsomme eller har en høj ressourceudnyttelse. Dette kan være et spørgsmål ved overvågning af ECS eller fundet som en del af normal brug.

Årsag

Flere faktorer såsom netværksrelaterede problemer, høj belastning og brugsmønstre osv.

Løsning

    Spørgsmål, der bør overvejes, når du oplever en forringelse af ydeevnen. (Forvent at teknisk support anmoder om svar på nedenstående forespørgsler)

    • Hvilken adfærd eller hvilke symptomer opleves der, som indikerer et problem med ydeevnen?

    • Hvad er virkningen af problemet?

    • Hvornår konstateredes ydeevneproblemet først?

    Er der foretaget ændringer i miljøet for nylig?

    • Software eller hardware?
    • Indlæse?
    • Netværk?
    • Firewall?
    • Belastningsfordeling?
    • Kan problemet udtrykkes i form af ventetid eller driftstid
    • Hvad er miljøet? Bruges software og hardware? Versioner? Konfiguration? Kundeapplikation?
    • Hvad er den gennemsnitlige filstørrelse (store og små filer)?
    • Påvirkes læsning, skrivninger, sletninger eller opdateringer? Eller alle berørte metoder?
    • Mulighed for at læse eller skrive ved hjælp af andre adgangsmetoder? Er et bestemt program berørt, eller er alle programmer berørt?

    Hvilken adgangsmetode anvendes:
    • S3
    • Swift
    • Centera SDK (CAS) Er der en overførsel/ECSsync eller anden migrering i gang?
    • Filsystemadgang:
    • Windows, der bruger CIFS (geodrive)
    • Linux, der bruger NFS
    Hvad er applikationsadgangsmønsteret?
    POST opretter og omdøber objekter.
    GET henter objektdata.
    PUT-opdateringer af
    objektattributter SLET fjerner objekter og metadata fra systemet.
    HEAD svarer til hver GET-metode. HEAD ligner nøjagtigt en GET-anmodning, bortset fra at metodenavnet er HOVED i stedet for HENT.
    Svaret på en HEAD-anmodning omfatter kun overskrifter; det omfatter ikke en svartekst.
    • Opretter dit program forbindelse til alle eller nogle individuelle noder? Er en belastningsfordeling konfigureret?

    • Kan navneområdet angives, bucket-hemmelighed og UID for det berørte program, så vi kan udføre lignende test på ECS?

     

    Oplysninger, der skal indsamles på ECS, hvis du åbner en serviceanmodning hos teknisk support for at hjælpe med at indsnævre problemløsningen

    • Programlogfiler fra berørte programmer, der er specifikke for en mislykket anmodning eller forsinket anmodning, er mest fordelagtige her.
    • Eventuelle observationer fra ECS-brugergrænsefladen som i en node offline eller andre kritiske fejl, der observeres fra dashboard-menuen
    • Svar på spørgsmål fra forrige afsnit
    • Xdoctor kører, hvis det berørte system ikke har dialhome-funktion.

    Egenskaber for artikel


    Berørt produkt

    Elastic Cloud Storage

    Produkt

    ECS Appliance, Elastic Cloud Storage

    Sidste udgivelsesdato

    17 feb. 2023

    Version

    3

    Artikeltype

    Solution